Closed Bug 317876 Opened 14 years ago Closed 13 years ago

Crash with evil testcase on hovering after reload with display:table-row, display:inherit

Categories

(Core :: Layout: Tables, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

VERIFIED FIXED

People

(Reporter: martijn.martijn, Assigned: bzbarsky)

References

Details

(4 keywords)

Attachments

(3 files)

See upcoming testcase.

To reproduce the crash:
- Load testcase
- Hover over the text
- Reload
- Hover over the text
- Reload

Also happens in Mozilla1.7
Attached file testcase
Backtrace from debug build, from the assertion I get.
It doesn't seem to crash in a debug build, though.
The display type asserts are the debug help patch from bug 289517 that got checked in without r/sr.
Depends on: 289517
fixed by the checkin for bug 289517
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
reading the bug sometimes helps :-(
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
So is this still an issue now that bug 289517 is fixed?
(In reply to comment #6)
> So is this still an issue now that bug 289517 is fixed?

Not with 2005-12-22-10 of trunk SeaMonkey on Windows XP, no.
Status: REOPENED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → FIXED
Stephen did you see comments 4 and 5, I reopened because I first believed that it got fixed and later discovered that is not the case, You have to reload the testcase as the bug description says: TB13223205Z
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #8)
> Stephen did you see comments 4 and 5, I reopened because I first believed that
> it got fixed and later discovered that is not the case, You have to reload the
> testcase as the bug description says: TB13223205Z

Bernd, yes indeed that's the case.  Sorry ;-(

It took a while--I had to browse away from the page to get it to crash, but I did.
The style display resolution is still wrong even after the patch for bug 289517.
Undoing https://bugzilla.mozilla.org/show_bug.cgi?id=289517#c27 fixes the assert and the crash. So from my reading of bug 289517 we need to fix the static case first to get the patch back in. But is static the right word here? Don't we need to fix the ordinary table cell creation aka bug 323656?
Boris, could you provide some guidance for this?
Yeah, the static case is bug 323656.

Could we perhaps do something for branch where we skip over the parent cellContent if and only if its parent is a pseudo-cell?  That shouldn't cause the sorts of issues bug 289517 comment 26 talks about, at least.

For trunk, we should fix bug 323656 and possibly in general fix how we determine our parent style context...
Depends on: 323656
Flags: blocking1.9a1?
Flags: blocking1.9a1? → blocking1.9+
Blocks: 372376
Now that bug bug 323656 is fixed, is this still a problem?
no more crash

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070416 Minefield/3.0a4pre ID:2007041607 [cairo]
Yes, seems fixed, no crash on reload anymore, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070417 Minefield/3.0a4pre
Status: REOPENED → RESOLVED
Closed: 14 years ago13 years ago
Resolution: --- → FIXED
Flags: in-testsuite?
Verified fixed on trunk and branches.
The testcase doesn't crash anymore when hovering over the text and then reloading.
Status: RESOLVED → VERIFIED
Assignee: martijn.martijn → bzbarsky
You need to log in before you can comment on or make changes to this bug.