Onmouseover/Onmouseout cease to function

VERIFIED FIXED

Status

()

Core
Event Handling
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Ted Ashton, Assigned: joki (gone))

Tracking

({testcase})

Trunk
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE])

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
If the mouse is moved onto the picture from the sidebar or from the menu bar,
the onmouseover/onmouseout functions cease to switch the picture, though they
continue to be called (note that "First" and "Second" tradeoff in the title even
on the first mouseout event in which the "help" stays white).  The problem does
not occur every time, but happens on my machine within about 3 tries if I move
my mouse down through "Bookmarks" and "Tinderbox" and on to the picture.
(Reporter)

Comment 1

18 years ago
Created attachment 6524 [details]
testcase
(Reporter)

Updated

18 years ago
Keywords: testcase
Whiteboard: [TESTCASE]

Comment 2

18 years ago
ashted, you said this in bug 30578:
------
the mouseout does fire even on the first failure, I
think that in the
31788 bug, the failure is that

theObj = eval(MM_swapImage.arguments[(navigator.appName ==
'Netscape')?i:i+1])

returns null sometimes when it oughtn't.
------
In M14, appName returned "Mozilla" instead of "Netscape".  So if you are running
M14, it is probably that bad browser sniffing is at work.  It's been fixed,
though.  Can you try a recent build?
(Reporter)

Comment 3

18 years ago
Just downloaded the latest Nightly Build--symptoms remain.

Comment 4

18 years ago
See my comment on #30578, 

Comment 5

18 years ago
Not an engine bug.
Assignee: rogerl → joki
Component: Javascript Engine → Event Handling
QA Contact: rginda → janc

Comment 6

18 years ago
Created attachment 7202 [details]
Shows onmouseout failure for a <p> element.

Comment 7

18 years ago
I believe this is broader than it previously seemed; any elements with both 
'onmouseover' and 'onmouseout' fail to trigger 'onmouseout' at all.  Attaching 
testcase that exhibited the problem using a late March nb1b nightly.  I've 
noticed a number of other bugs that might be caused by this (search for 
'onmouseout' in the summary).
(Assignee)

Comment 8

18 years ago
This does seem to be broken in the beta branch for some reason but works fine on 
the tip.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 9

18 years ago
Mass update:  changing qacontact to ckritzer@netscape.com
QA Contact: janc → ckritzer

Comment 10

17 years ago
Updating QA Contact.
QA Contact: ckritzer → lorca

Comment 11

17 years ago
Works for Me
Platform: PC
OS: Windows 98
Build # 2000100508

Marking as Verified
Status: RESOLVED → VERIFIED

Comment 12

17 years ago
Usual Suspect-did you verify this in a trunk or branch build?  Might want to note 
that, since it may be fixed in one and not the other...Honestly, I've been using 
commercial branch builds and have had no problem with mouseout or over.

Comment 13

17 years ago
I am using the Trunk Build...sorry for not putting that in :)
You need to log in before you can comment on or make changes to this bug.