Multiple visits when using apache's mod_rewrite

RESOLVED INVALID

Status

()

RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: murfy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

When I use .htaccess (the mod_rewrite) module to rewrite my url's (e.g. index.php?page=foo is displayed as foo.html), Firefox visits the url's more than once.

You can see this at http://www.westroute.be/ . When you visit the site, there will be a 1 on top of the page. Click "Home" or another link, and you will see the number increases with 5 or more.

As a result of this, my stats are totally wrong, so i think a lot of webdesigners won't be happy with this.

Reproducible: Always

Steps to Reproduce:
1. Visit www.westroute.be .
2. Watch the number at the top of the page.
3. Click a link on the page.
4. Watch the number again.

Actual Results:  
The same as I described above.

Expected Results:  
The number should increase with one at the time (of course).
WFM. Every click of home increased the number by 1.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5 ID:2005111116
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> WFM. Every click of home increased the number by 1.
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111
> Firefox/1.5 ID:2005111116
> 

That's weird..

I installed 1.5 RC3 and the problem occured. I tested it again with 1.0.4 and it worked normally. Using Internet Explorer it also worked as it should.. :s
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051124 Firefox/1.5 ID:2005112403
WFM.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051126 Firefox/1.6a1 ID:2005112623
WFM.
(Reporter)

Comment 4

13 years ago
I'm sorry, i just found out this has to do with the Fasterfox extension. I tested it on another pc.

So this is not a bug, sorry for the inconvience.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 5

13 years ago
Is this due to a bug in Fasterfox?  If so, it should be reported the Fasterfox people...
You need to log in before you can comment on or make changes to this bug.