Closed Bug 318068 Opened 19 years ago Closed 15 years ago

Firefox crash on password protected FTP [@ nsFTPChannel::GetFTPEventSink]

Categories

(Core Graveyard :: Networking: FTP, defect)

1.8 Branch
x86
Windows XP
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: sendmail.to, Unassigned)

Details

(Keywords: crash)

Crash Data

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051107 Firefox/1.5

The "Steps to Reproduce"

Reproducible: Always

Steps to Reproduce:
1. login to a password protected FTP Server (into servers root)
2. use the link to switch to the next higher folder (i.e. /../) 
3. if you are double(or more) clicking on this link, Firefox opens a new password Dialog.
4. With the correct timing Firefox will crash (just countinue clicking on the Link)



Expected Results:  
There should be no further password dialog after logged in. Why does Firefox do this?
And of course Firefox should not crash.

Unfortunately i can't post the server with login and pw.
Captures with Ethereal:

Response: 227 Entering Passive Mode (IP,IP,IP,IP,204,247).
Request: SIZE /../../../
Response: 550 /../../../: not a regular file
Request: MDTM /../../../
Response: 550 /../../../: not a plain file.
Request: RETR /../../../
Response: 550 /../../../: Not a regular file
Response: 220 FTP SERVER
Request: USER anonymous
Response: 331 Password required for anonymous.
Request: PASS mozilla@example.com
Response: 530 Login incorrect.
Response: 220 FTP SERVER
Request: USER anonymous
Response: 331 Password required for anonymous.
Request: PASS mozilla@example.com
Response: 530 Login incorrect.
Request: USER XXXXXX
Response: 331 Password required for XXXXXX
Request: PASS YYYYYY
Response: 230 User XXXXXX logged in.
Request: SYST
Response: 215 UNIX Type: L8
Request: PWD
Response: 257 "/" is current directory.
Request: TYPE I
Response: 200 Type set to I
Request: PASV
Response: 227 Entering Passive Mode (IP,IP,IP,IP,204,248).
Request: SIZE /../../../
Response: 550 /../../../: not a regular file
Request: MDTM /../../../
Response: 550 /../../../: not a plain file.
Request: RETR /../../../
Response: 550 /../../../: Not a regular file
Request: PASV
Response: 227 Entering Passive Mode (IP,IP,IP,IP,204,249).
Request: CWD /../../../
Response: 250 CWD command successful.
Request: LIST
Response: 150 Opening ASCII mode data connection for file list
Response: 226 Transfer complete.
Could you install with talkback and get a talkback ID for the crash? http://kb.mozillazine.org/Talkback
if you really mean crash, can you please install talkback and provide an incident id?
Assignee: nobody → dougt
Component: General → Networking: FTP
Product: Firefox → Core
QA Contact: general → benc
Version: unspecified → 1.8 Branch
I have reproduced this Bug on a second PC with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051129 Firefox/1.5

And send a Talkback TB12381557K
Incident ID: 12381557
Stack Signature	nsFTPChannel::GetFTPEventSink 0bfc780a
Product ID	Firefox15
Build ID	2005112903
Trigger Time	2005-11-29 06:11:17.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	firefox.exe + (000794c3)
URL visited	
User Comments	See BUG318068
Since Last Crash	82 sec
Total Uptime	82 sec
Trigger Reason	Access violation
Source File, Line No.	c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/netwerk/protocol/ftp/src/nsFTPChannel.cpp, line 357
Stack Trace 	
nsFTPChannel::GetFTPEventSink  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/netwerk/protocol/ftp/src/nsFTPChannel.cpp, line 357]
nsFtpState::SendFTPCommand  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/netwerk/protocol/ftp/src/nsFtpConnectionThread.cpp, line 2526]
nsFtpState::S_user  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/netwerk/protocol/ftp/src/nsFtpConnectionThread.cpp, line 1074]
nsFtpState::Process  [c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/netwerk/protocol/ftp/src/nsFtpConnectionThread.cpp, line 758]
Keywords: crash
Summary: Firefox crash on password protected FTP → Firefox crash on password protected FTP [@ nsFTPChannel::GetFTPEventSink]
Hrm... supposedly bug 308018 fixed this.

*** This bug has been marked as a duplicate of 308018 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
reopening... the dates don't match up.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
mass reassigning to nobody.
Assignee: dougt → nobody
This Bug is still UNCONFIRMED.

And I have no test System any more.

Can I close this Bug? Or is there any chance to get this fixed by using the stack Trace?
If yes, which resolution?
In response to comment #9: Since the issue hasn't appeared again and it hasn't appeared in the most recent stable version of Firefox, I am resolving this as Worksforme, which is the most accurate resolution for this kind of issue.

Should the issue reappear, we will reopen the bug.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago15 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsFTPChannel::GetFTPEventSink]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.