blackboard.com - Blackboard course software does not support rich text editor in Gecko

RESOLVED FIXED

Status

Tech Evangelism
Desktop
RESOLVED FIXED
13 years ago
4 years ago

People

(Reporter: Frank van Herwaarden, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/416.11 (KHTML, like Gecko) Safari/416.12
Build Identifier: Camino 0.8.4 and 1.0b

For a moment I was happy, because in the Blackboard environment Camino seems to be the only browser for MacOS X that displays a toolbar of layout possibilities in Blackboard control panels. I was happy because I find it very annoying that in Bb on each PC one can use Bold, coloured text, underlined, etc. but in none of the MacOS X browsers you can. Camino sows the toolbar, but .......... unfortunately it does NOT provide the the text input form field. Therefore,..... there is nothing to edit. Displaying this for field correctly would make camino my number one browser for the Mac, being the only one to behave correctly in Blackboard!

Reproducible: Always

Steps to Reproduce:
1.Always happens
2.In fact it is an enhancement feature request
3.

Actual Results:  
I'm not able to put in any text

Expected Results:  
show the input text form field.

I'm quite willing to provide you with screenshots that will show exactly what I mean. A problem is that one has to be enrolled in Blackborad to be able to see the problem. I do not know if the problem shows up in a similar manner in other sites!? Just let me know if I should sent in my screenshots, or how I can add the to this information.
I assume you're talking about a rich-text editor widget (looking something like http://www.mozilla.org/editor/midasdemo/) somewhere in Blackboard?  Is it also broken the same way in Firefox 1.5RC3?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> I assume you're talking about a rich-text editor widget (looking something like
> http://www.mozilla.org/editor/midasdemo/) somewhere in Blackboard?  Is it also
> broken the same way in Firefox 1.5RC3?
> 
In fact Camino seems to be the only Mac browser so far that does show the rich-text editor!
(You are right it looks similar.) But it does NOT show a formfield where you can enter the text itself!
So the editor is there, but no txt to be edited!
In other browsers it is the other way around!
Only Windows $%%&*&@@#!@ seems to be able to show Blackboard correctly!
Frank, are you saying in your last comment that the rich-text editor does not appear or does not work in Camino but does appear and works properly in Firefox 1.5/Mac?

(The cause of the problem is different depending on whether it only is missing in Camino or missing/broken in both Camino and Firefox.)
(Reporter)

Comment 4

13 years ago
I do not knw how to make it more clear.
In Firefox (and all other MAC-browsers I know): A text form field where you can add things like commands, but only with the most simple text editor (choices like HTML or plain text).
In Camino: NO text form field, BUT a RICH text field editor with all lay-out options.
In Windows PC's: Both a form field and a rich text editor.
If I coud add some screenshots? (I'm new to this forum!)
(In reply to comment #4)
> If I coud add some screenshots? (I'm new to this forum!)
Yes, please; that will help me :-)

Use the "Create New Attachment" link above, which will prompt you to upload the images (.png or .jpg, please--not .pdf, so use Preview to convert them first).

(Reporter)

Comment 6

13 years ago
Created attachment 204777 [details]
Text editor and text form field in safari (same in firefox)
(Reporter)

Comment 7

13 years ago
Created attachment 204778 [details]
RICH text editor text form field missing in camino
My best guess about what is happening, based on your descriptions and screenshots, without being able to pick at the blackboard code, is that the rich-text editor in Blackboard is not programmed to work with Gecko-based browsers (or with Safari), so Blackboard is doing browser-sniffing and forcing Firefox and Safari to use the normal editor.  Its browser-sniffing is "broken" in that it doesn't recognize Camino and lets Camino have the rich-text version anyway, which doesn't work (because the rich-text editor is probably WinIE-only).

You can test this theory by using user-agent spoofing in Camino and Firefox, and that's likely the cause if Camino, pretending to be Firefox, gets the same regular editor as Firefox did in the screenshot, and Firefox, pretending to be Camino, gets the same rich-but-broken editor as Camino did in the screenshot.

http://www.caminobrowser.org/support/sup_hiddenprefs.html#SpoofUserAgent for instructions (when you're done, you'll have to remove the line from both user.js and prefs.js)

Enter 
javascript:document.write(navigator.userAgent)
in your location bar before you start to get the user-agent string from each browser to use in the spoofing pref.

(Mike, you don't have access to Blackboard for your course at GWU, do you?  I poked around GU's, but couldn't find any classes that appeared to use this widget.)
(Reporter)

Comment 9

13 years ago
With help of my genious son I have tested this and you were right! 
I'm afraid that I wil have to wait for an update of Blackboard readying it for use with Mozilla for MAC browsers or for an update of Mozilla that is able to deal with Bb. I'll see if I can p[ost it at a Bb forum also!
THANX!!

(In reply to comment #8)
> My best guess about what is happening, based on your descriptions and
> screenshots, without being able to pick at the blackboard code, is that the
> rich-text editor in Blackboard is not programmed to work with Gecko-based
> browsers (or with Safari), so Blackboard is doing browser-sniffing and forcing
> Firefox and Safari to use the normal editor.  Its browser-sniffing is "broken"
> in that it doesn't recognize Camino and lets Camino have the rich-text version
> anyway, which doesn't work (because the rich-text editor is probably
> WinIE-only).
> 
> You can test this theory by using user-agent spoofing in Camino and Firefox,
> and that's likely the cause if Camino, pretending to be Firefox, gets the same
> regular editor as Firefox did in the screenshot, and Firefox, pretending to be
> Camino, gets the same rich-but-broken editor as Camino did in the screenshot.
> 
> http://www.caminobrowser.org/support/sup_hiddenprefs.html#SpoofUserAgent for
> instructions (when you're done, you'll have to remove the line from both
> user.js and prefs.js)
> 
> Enter 
> javascript:document.write(navigator.userAgent)
> in your location bar before you start to get the user-agent string from each
> browser to use in the spoofing pref.
> 
> (Mike, you don't have access to Blackboard for your course at GWU, do you?  I
> poked around GU's, but couldn't find any classes that appeared to use this
> widget.)
> 

Simon, Mike: Is there any value in turning this bug into a Tech Evangelism bug for the Blackboard product, or should we just close invalid?
we should. blackboard is fairly common.
Assignee: mikepinkerton → english-us
Status: UNCONFIRMED → NEW
Component: HTML Form Controls → English US
Ever confirmed: true
Product: Camino → Tech Evangelism
QA Contact: english-us
Summary: Camino does not display text input form field in Blackboard environment → blackboard.com - Blackboard course software does not support rich text editor in Gecko

Comment 12

9 years ago
Did anyone ever contact Blackboard about this?

I've recently received a report that Blackboard now refuses to work with any Mac browser *except* Firefox. (I'm looking into this further, but it'd be nice to have a Blackboard login somewhere to play with.)
OS: Mac OS X → All
Hardware: PowerPC → All
The original domain name of this bug doesn't exist anymore.

→ ping blackboard.hsleiden.nl
PING blackboard.hsleiden.nl (195.169.84.130): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
Request timeout for icmp_seq 5

The blackboard Web site is still up.
http://www.blackboard.com/

The list of browsers supported is given at 
http://kb.blackboard.com/display/IDSR/Student+and+Faculty+Support+Resource+Center

The last version seems to be compatible
http://kb.blackboard.com/pages/viewpage.action?pageId=72810639
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: English US → Desktop
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.