Tab insertion marker doesn't disappear when dragging a tab into the content area

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
13 years ago
3 years ago

People

(Reporter: Andy Lyttle, Unassigned)

Tracking

2.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
1. Open multiple tabs
2. Drag a tab to the side, so the little purple arrow appears
3. Continue dragging down into the content area
4. Release the drag

At this point the page reloads (silently erasing any form input, which I'm sure is another bug).  However, the little purple arrow is still there!  Or, it may have disappeared when you dragged into the content area, then reappeared on mouseup.

This bug does not seem to occur on Linux; I haven't tested Windows.
(Reporter)

Updated

13 years ago
Severity: normal → minor

Updated

12 years ago
Severity: minor → normal
Version: 1.5.0.x Branch → 2.0 Branch

Comment 1

12 years ago
Bug 333791 might fix this.
Depends on: 333791

Comment 2

12 years ago
I was unable to reproduce it using 2.0RC1, so I think that this has been fixed as was suggested by the previous commenter.

I do agree that you have turned up another bug that should be reported if it hasnt been already. Dragging the active tab into its own content area should not cause a page refresh.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 3

12 years ago
Resolving as WORKSFORME since we're not sure what patch fixed this.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME

Comment 4

3 years ago
Created attachment 8630008 [details]
Screen Shot 2015-07-06 at 9.24.08 AM.png

I've seen this a couple times recently where, after dragging a tab into the browser set, the landing marker stays where it landed and doesn't go away. Scrolling through tabs leaves it floating over other tabs until I minimize Firefox and re-open it.
You need to log in before you can comment on or make changes to this bug.