Minimonth header for February displays 'March' when today's date is > 28

RESOLVED FIXED

Status

Calendar
General
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Thib, Assigned: Mostafa Hosseini)

Tracking

Details

(Whiteboard: [good first bug])

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051104 Mozilla Sunbird/0.3a1

The top-left calendar tab and the date picker in various dialogs shows two months with the title March 2006 in a row, one of which clearly being February 2006. On #calendar there seems to be a clue it would occur when the day is > 28.

Reproducible: Always

Steps to Reproduce:
1. Open Sunbird. (Today is the 29th.)
2. Click on the Date tab (top-left).
3. Browse to 2006.

Actual Results:  
There are two March 2006 in a row, one for February and one for March.

Expected Results:  
There should be one February 2006 and one March 2006.

Comment 1

13 years ago
Confirmed in 20051127 nightly only when the operating system's current date is > 28.

We're getting a js-date rollover somewhere in minimonth.xml.  Since the current date is > 28, setting the month to be february results in march actually appearing when js-date corrects itself.  I suspect you might see something similar if the current date was 31 in months of only 30 days.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Duplicate March 2006 (when day > 28?) → Minimonth header for February displays 'March' when today's date is > 28
Whiteboard: [good first bug]
Created attachment 204592 [details] [diff] [review]
patch

Ensure that day of month is <28 for tempDate to avoid rollover.
Attachment #204592 - Flags: first-review?(jminta)

Comment 3

13 years ago
Comment on attachment 204592 [details] [diff] [review]
patch

Thanks for the patch!

r=jminta
Attachment #204592 - Flags: first-review?(jminta) → first-review+

Comment 4

13 years ago
patch checked in
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 5

13 years ago
*** Bug 322019 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
*** Bug 325284 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.