Bug 318250 (CSS_background_image)

CSS problem - image background into a cell table is anormal scaled on printing

RESOLVED DUPLICATE of bug 161179

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 161179
13 years ago
13 years ago

People

(Reporter: Yves, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

When I use the "no-repeat" option into the "background: url("images/topquote.png");" style (CSS), [the image maybe also a jpg or gif, the problem is the same], into a cell of a table, the image isn't well printed on the paper. When you do a "preview before printing", the image seems correct, but when the image is printed on the document, he is scaled into a smaller size (+-80% less than normal size).
You can do a test by yourself with this url "http://developer.mozilla.org/samples/cssref/background.html" and the last version of Firefox, with a Windows 2000 professional

Reproducible: Always

Steps to Reproduce:
1.Go to http://developer.mozilla.org/samples/cssref/background.html
2.Do a "print preview" into the "file" menu toolbar
3.Print your your document on the paper

Actual Results:  
the background image is scaled into smaller size than the normal size

Expected Results:  
print the background image with the same size like the "print preview"

If you delete the "no-repeat" option into the cascading style of the background image, the bug problem is resolved.

WRONG:
.quotation {
	background: url("images/topquote.png") #c6c6c6 top left no-repeat;
	padding: 15px;
	width: 300px;
}

RIGHT:
.quotation {
	background: url("images/topquote.png") #c6c6c6 top left;
	padding: 15px;
	width: 300px;
}
(Reporter)

Updated

13 years ago
Alias: CSS_background_image

*** This bug has been marked as a duplicate of 161179 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.