ff 1.5 does not display the information in the java applet

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: tva995, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

just downloaded ff 1.5   it does not display information in java applets... speed test on dslreports.com or annotated charts on stockcharts.com..

Reproducible: Always

Steps to Reproduce:
1.go to referenced web sites
2.click on link to activate java applet window
3.behold blank or empty applet windows.

Actual Results:  
no info in applet window

Expected Results:  
want applet to show chart to annotate or speed test button to push...  ff 1.5 does not produce the result.
Works For Me: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

If you've got any types of filtering extensions installed (like Adblock), try disabling them and see if that makes any difference.

Comment 2

13 years ago
Same problem in Windows 2000.  After a lot of research, seems to be a problem with the z order in Java.  Did find the following fix from Jason Purdy, Java Product Manager with Stingray Software, in his paper "Write Once, Run Anywhere".

String osName = System.getProperty("os.name");
if (osName.equals("Windows NT")||osName.equals("Windows 95")
    ||osName.equalsIgnoreCase("macos")
    ||osName.equalsIgnoreCase("mac os")) {
	// add components from top to bottom (z-order wise)
} else {
	// add components from bottom to top (z-order wise)
}

WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.