[4.xP] Unable to open www.foo.com:/some/dir (note colon)

VERIFIED FIXED in M15

Status

()

Core
Networking
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: dougw, Assigned: Judson Valeski)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [4.xP], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; N; Linux 2.2.14 i586; en-US) Mozilla/m14
BuildID:    2000030316

When right clicking on an ftp:// link and selecting open in new window the
window opens without loading the ftp:// link. The link is not present in the
location field in the new window either.

Reproducible: Always
Steps to Reproduce:
1. Got to a web page with links to ftp sites.
2. Right click the ftp link
3. Select open link in new window


Actual Results:  New window opens without loading the ftp site. The url to the
ftp site is not placed in the location field.

Expected Results:  The new window should load the ftp site when opened. The url
to the ftp site should be placed in the location field.

This is the link where I first discovered the problem:
http://shelob.ce.ttu.edu/daves/lpfaq/faq-10.html
There is a link to an ftp site under availability for C2Latex.
How exactly were you using 2000030316 when the bug was filed on 2000-03-14?

The reason this is failing is that the link in the page is to:
ftp://omnigate.clarkson.edu:/pub/tex/tex-programs/c2latex

Note the extra colon without a port number.

FTP Open In New Window works with non-odd links.

However, NS 4.72 does cope with this form of URL, so this is a [4.xP] bug. This 
problem also occurs for HTTP URLs.

Confirming, rewriting title, moving to Networking.

Gerv
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking
Ever confirmed: true
Summary: Selecting Open link in new window on an ftp:// link does not load ftp site. → [4.xP] Unable to open www.foo.com:/some/dir (note colon)
Whiteboard: [4.xP]
Reassigning to owner of selected component (Oops).

Gerv
Assignee: cbegle → gagan
QA Contact: asadotzler → tever

Comment 3

18 years ago
Created attachment 6991 [details] [diff] [review]
patch to fix the problem

Comment 4

18 years ago
Gagan: Assign the bug to me if you want, please review the patch.

Comment 5

18 years ago
Jud, can you review this?
Assignee: gagan → valeski
Target Milestone: --- → M15
(Assignee)

Comment 6

18 years ago
r=valeski. what's the [4.xP] notation?

Comment 7

18 years ago
fix checked in.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

17 years ago
Blocks: 63736

Comment 8

17 years ago
qa to me.

VERIFIED:
Mozilla 0.9 Linux and Win32.

The submitted URL points to a server that is down, but I also tested the general
format:

ftp://ftp.netscape.com:/

To make sure we just ignore the colon and use the well-known port.
Status: RESOLVED → VERIFIED
QA Contact: tever → benc

Comment 9

17 years ago
MacOS too.
You need to log in before you can comment on or make changes to this bug.