bug at landfill.bugzilla.org : if a search is saved with a name containing UTF-8 characters this name is not shown properly at all pages containing "Saved Searches:"

RESOLVED INVALID

Status

()

Bugzilla
Query/Bug List
--
trivial
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: lɛʁi לערי ריינהארט, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Hallo!

Bug opened as requested at bug 126266 comment 268 .

15 minutes ago I saved a search at http://landfill.bugzilla.org/bugzilla-tip/ with the name
- irc:LpSolit - Frédéric BUCLIN

"Saved Searches:" shows
My Bugs | ‑ irc:LpSolit ‑ Fr�d�ric BUCLIN | ...
at
http://landfill.bugzilla.org/bugzilla-tip/show_bug.cgi?id=3198
http://landfill.bugzilla.org/bugzilla-tip/enter_bug.cgi

But it displays *properly* at the bottom of
http://landfill.bugzilla.org/bugzilla-tip/buglist.cgi?cmdtype=runnamed&namedcmd=-%20IRC%3ALpSolit%20-%20Fr%E9d%E9ric%20BUCLIN
http://landfill.bugzilla.org/bugzilla-tip/buglist.cgi?cmdtype=runnamed&namedcmd=-%20%5B%5BGangleri%5D%5D%20Reinhardt%20WIEWE
http://landfill.bugzilla.org/bugzilla-tip/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&email1=gangleri%40wikimagic.com&emailtype1=exact&emailassigned_to1=1&emailreporter1=1

at https://bugzilla.mozilla.org/enter_bug.cgi?product=Bugzilla
s similar search shows properly
also at https://bugzilla.mozilla.org/votes.cgi?action=show_user
and https://bugzilla.mozilla.org/show_bug.cgi?id=318116

regards reinhardt [[user:gangleri]]

Reproducible: Always

Steps to Reproduce:
you need some time to verify what you see in "Saved Searches:" at different pages.

Actual Results:  
The saved search names shows differently at various pages.

Expected Results:  
It should display the same way all over.
(Reporter)

Comment 1

12 years ago
P.S. https://bugzilla.mozilla.org/process_bug.cgi has / shows the same error:
"Saved Searches:"
My Bugs | ‑ irc:LpSolit ‑ Fr�d�ric BUCLIN | 
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> P.S. https://bugzilla.mozilla.org/process_bug.cgi has / shows the same error:
> "Saved Searches:"
> My Bugs | ‑ irc:LpSolit ‑ Fr�d�ric BUCLIN | 

but sporadical; first submit showed the error, the seccond *not*
(Reporter)

Comment 3

12 years ago
*notes*
a)
https://bugzilla.mozilla.org/buglist.cgi?newquery=query_format%3Dadvanced%26short_desc_type%3Dallwordssubstr%26short_desc%3D%26long_desc_type%3Dallwordssubstr%26long_desc%3D%26bug_file_loc_type%3Dallwordssubstr%26bug_file_loc%3D%26status_whiteboard_type%3Dallwordssubstr%26status_whiteboard%3D%26keywords_type%3Dallwords%26keywords%3D%26emailassigned_to1%3D1%26emailreporter1%3D1%26emailqa_contact1%3D1%26emailcc1%3D1%26emaillongdesc1%3D1%26emailtype1%3Dexact%26email1%3Dlpsolit%2540gmail.com%26emailassigned_to2%3D1%26emailreporter2%3D1%26emailqa_contact2%3D1%26emailtype2%3Dexact%26email2%3D%26bugidtype%3Dinclude%26bug_id%3D%26votes%3D%26chfieldfrom%3D%26chfieldto%3DNow%26chfieldvalue%3D%26query_based_on%3D-%2520%255B%255BGangleri%255D%255D%26field0-0-0%3Dnoop%26type0-0-0%3Dnoop%26value0-0-0%3D&cmdtype=doit&remtype=asnamed&newqueryname=-+irc%3ALpSolit+-+Fr%E9d%E9ric+BUCLIN
returned
OK, you have a new search named - irc:LpSolit - Frédéric BUCLIN.

Maybe the title is wrong. UTF-8 should probably be ISO/IEC_8859-1.
( http://en.wikipedia.org/wiki/ISO/IEC_8859-1 )

b)
When traying to save another search as
- [[גאַנגלערי]]
or
גאַנגלערי
I received
Illegal Search Name
The name of your search cannot contain any of the following characters: <, >, &.

c)
In comment 0 you see that é is sometimes replaced by &#65533;
Unicode Character REPLACEMENT CHARACTER U+FFFD
http://www.fileformat.info/info/unicode/char/fffd/index.htm
HTML Entity (decimal)  	&#65533;
HTML Entity (hex) 	&#xfffd;
UTF-8 (hex) 	0xEF 0xBF 0xBD (efbfbd)
Ok, this was not a bug in Bugzilla. The utf8 parameter on landfill hadn't been switched on yet. It should work now. (The queries you've saved until now are possibly still broken and may need a rename.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.