Last Comment Bug 318888 - Color of download icon in prefs should match toolbar icon
: Color of download icon in prefs should match toolbar icon
Status: RESOLVED FIXED
: fixed1.8.1, polish
Product: Camino Graveyard
Classification: Graveyard
Component: Toolbars & Menus (show other bugs)
: unspecified
: PowerPC Mac OS X
-- enhancement (vote)
: Camino1.5
Assigned To: Jon Hicks
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-03 01:26 PST by davedit
Modified: 2006-09-14 18:27 PDT (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
proposal for new "downloads" icon (109.84 KB, image/png)
2005-12-29 06:09 PST, Jasper
no flags Details
2nd attempt (1.25 KB, image/png)
2005-12-29 10:30 PST, Jasper
no flags Details
2nd preview (92.56 KB, image/png)
2005-12-29 10:33 PST, Jasper
no flags Details
3d attempt (33.13 KB, image/png)
2006-01-05 12:06 PST, Jasper
no flags Details
3d attempt tiff file (2.08 KB, image/tiff)
2006-01-05 12:07 PST, Jasper
no flags Details
Revised dl_manager.tif icon with green arrow (1.57 KB, image/tiff)
2006-09-13 15:03 PDT, Jon Hicks
samuel.sidler+old: review+
mikepinkerton: superreview+
Details

Description User image davedit 2005-12-03 01:26:21 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051201 Camino/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051201 Camino/1.0+

I think the color of the download arror in dl_manager.tif should match the color of the Downloads pref pane icon for consistency. The green in new Downloads pref pane icon is nice, but if it were used in dl_manager.tif, it might clash with the charteruse. Perhaps a nice peach or gold? Just a suggestion.

Reproducible: Always
Comment 1 User image Samuel Sidler (old account; do not CC) 2005-12-03 01:28:28 PST
I concur. Whatever color we choose, it should be consistent over both icons.

Jasper, can you look at this?
Comment 2 User image Jasper 2005-12-29 06:09:42 PST
Created attachment 207069 [details]
proposal for new "downloads" icon

I tried to do the download metaphor in a different way. one that we already used actually. I propose to start using a box like we use for open to represent downloads. Attached is  a screenshot of the icon in action.
Comment 3 User image Simon Fraser 2005-12-29 09:22:44 PST
I think the box icon needs to be a little more isometric, because now it just looks 2D and I can't tell what the strip down the right side is. Nice idea though.
Comment 4 User image Jasper 2005-12-29 10:30:11 PST
Created attachment 207100 [details]
2nd attempt

I had a quick chat with Mike and we both agree that the current look is much to 2d to actually come accross as a box. I gave it a second thought, and doing an isometric view would be strange as we don't use it anywhere in our icons. So what I did was just use the same solution as I did with the Open icon, which is add the open top.
Comment 5 User image Jasper 2005-12-29 10:33:57 PST
Created attachment 207101 [details]
2nd preview

just to see
Comment 6 User image Jasper 2006-01-05 12:06:10 PST
Created attachment 207644 [details]
3d attempt

It's a minor change but for the good (thanks wevah for pointing this out.

I really don't think we should start doing icons in any "metric" kind of view. It will be very weird if we do so. I tried it, believe me.
Comment 7 User image Jasper 2006-01-05 12:07:53 PST
Created attachment 207645 [details]
3d attempt tiff file

Just so people can try it out.
Comment 8 User image Samuel Sidler (old account; do not CC) 2006-02-21 20:45:38 PST
1.0 has shipped and I don't think we should change the icon(s) in a maintenance release. Moving this to 1.1.
Comment 9 User image Smokey Ardisson (offline for a while; not following bugs - do not email) 2006-08-13 00:52:43 PDT
I really don't like the box, personally.
Comment 10 User image Jon Hicks 2006-09-13 15:03:00 PDT
Created attachment 238295 [details]
Revised dl_manager.tif icon with green arrow

As suggested, a version of the dl_manager.tif icon using the green arrow from the preferences icon for perusal.
Comment 11 User image Samuel Sidler (old account; do not CC) 2006-09-13 15:17:50 PDT
Comment on attachment 238295 [details]
Revised dl_manager.tif icon with green arrow

This new downloads window icon is for the toolbar. It simply matches the color of the one in preferences. We can rethink what we want the download icon to look like in a future bug but for now, to be consistent, I say we land this update the icon.

r=me
Comment 12 User image davedit 2006-09-13 17:27:49 PDT
The consistency is nice, but I think the color is too similar to manager.tif (unless this isn't a problem)
Comment 13 User image Samuel Sidler (old account; do not CC) 2006-09-13 17:34:25 PDT
(In reply to comment #12)
> The consistency is nice, but I think the color is too similar to manager.tif
> (unless this isn't a problem)

I don't see that as a problem. They're different enough icons that visually you can see a difference (in shapes, specifically).
Comment 14 User image davedit 2006-09-13 17:42:39 PDT
Ya that's true. But I think we also use colors as visual cues (for example, red for stop or emergencies), and that green color signifies bookmarking to me in Camino.
Comment 15 User image Samuel Sidler (old account; do not CC) 2006-09-13 17:45:04 PDT
(In reply to comment #14)
> for stop or emergencies), and that green color signifies bookmarking to me in
> Camino.

And back and forward... ;) We also use a slightly different green in our "add tab"  icon.

I really think this change is fine for now. We can revisit the icon later, but a brown icon isn't much of an improvement when green tends to mean "download" throughout the net.
Comment 16 User image Mike Pinkerton (not reading bugmail) 2006-09-14 09:20:52 PDT
Comment on attachment 238295 [details]
Revised dl_manager.tif icon with green arrow

sr=pink
Comment 17 User image Nick Kreeger 2006-09-14 10:17:59 PDT
Checked into trunk and MOZILLA_1_8_BRANCH

Note You need to log in before you can comment on or make changes to this bug.