The default bug view has changed. See this FAQ.

"Page Info" should be in the View menu

RESOLVED FIXED in Camino1.5

Status

Camino Graveyard
Toolbars & Menus
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Assigned: froodian (Ian Leue))

Tracking

({fixed1.8.1.1})

unspecified
Camino1.5
PowerPC
Mac OS X
fixed1.8.1.1

Details

Jasper and I were talking on irc about this; people aren't going to find/think to look for the Page Info menu item in the Edit menu.

Window was the first menu I looked in, and I finally tried cmd-i in desparation, hoping it would be the proper shortcut, before eventually finding the item in the Edit menu.

It makes more sense to put it up with Minimize and Zoom in the Window menu.

Comment 1

12 years ago
(In reply to comment #0)
> It makes more sense to put it up with Minimize and Zoom in the Window menu.

Don't you mean we should have it next to the Downloads menu item, so that we keep these aux window items together?

Comment 2

12 years ago
I disagree, for a copule of reasons:
1. Get Info is context-sensitive: it brings up the Bookmark Info window if you're in bookmarks.
2. Get Info isn't a normal window, it's a floating utility window, and so shouldn't be grouped with other windows in the menus.

Get Info in most other apps test to be towards the left of the menu bar (e.g. Finder has File->Get Info).

Comment 3

12 years ago
But in our case The Page Info window has nothing what so ever to do with Edit. So it's very very confusing. If it where in File I'd be OK or in window it be OK. But now it's just totally hidden. Why would a user ever look for it in Edit?

I'd also note that the info window in bookmarks is very different in that it also let's you edit bookmarks if wanted. Page Info window does not.

I also find it very confusing that there are two Get Info windows. I think we should have a Bookmarks Info Panel and a Page info window. See there are cases for example. You have the info window for a bookmark in the bookmark bare open and want to view the page info. It's very starnge to have both open with the same key combo but be different windows. It's totally confusing. 

I really think we should seperate them. There should be separate key combinations. And I think Page Info should be in window as it has nothing to do with Edit.

Comment 4

12 years ago
I agree with Simon that it has no business in the Window menu, but I also think it has approximately zero business in the Edit menu ;)

Why wasn't this put in the File menu, where Get Info is for every single other app that has a Get Info function?

cl
I don't think it belongs in either File or Edit.  

As Jasper noted, it's not an editing function (unlike the BM info pane, which is).  It's in the File menu in the Finder because it works on selected files, but there are no files here, although given our open/close tab functions are there, too, its not so out of place perhaps (of course, the other half of the window/tab manipulation commands are in the Window menu...).

Dunno.

Comment 6

12 years ago
(In reply to comment #5)
> but there are no files here, although given our open/close tab functions are

Sure there are -- the HTML file being viewed in the current view (tab or window).

The View menu might be an acceptable alternative, too.

cl

Comment 7

12 years ago
Yeah, I'm thinking View too.
So do we want 2 menu items, one for BM info window, and one for Page Info? Or do we leave Get Info bringing up the bookmark info window?
I think the BM Info wouldn't seem too out of place if it were in View, too--and I agree with Simon's comment 2 point 1.  

Putting both in the View menu seems to be a good compromise.
Flags: camino1.0?
Summary: "Page Info" should be in the Window menu → "Page Info" should be in the View menu
Target Milestone: --- → Camino1.0

Comment 9

11 years ago
Although I was desperately looking for the menu item in "File" (for OS e cross-app consistency), I agree that "View" is a proper place. I suggest that, if it goes to "View", the label is changed to "Show Info" (1 single item for page and BM)
Moving back to 1.1 per irc; we need to be string complete and we've yet to reach a solid consensus on this.
Flags: camino1.0? → camino1.0-
Target Milestone: Camino1.0 → Camino1.1
Blocks: 328173

Comment 11

11 years ago
*** Bug 341093 has been marked as a duplicate of this bug. ***
Assignee: mikepinkerton → stridey
QA Contact: toolbars
(Assignee)

Comment 12

11 years ago
The fix for this is in bug 275170.
Depends on: 275170
(Assignee)

Comment 13

11 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Updated

11 years ago
Keywords: fixed1.8.1
(Assignee)

Updated

11 years ago
Keywords: fixed1.8.1.1
(Assignee)

Updated

11 years ago
Keywords: fixed1.8.1
You need to log in before you can comment on or make changes to this bug.