Last Comment Bug 319600 - New SeaMonkey throbber lives in grey square in Classic theme
: New SeaMonkey throbber lives in grey square in Classic theme
Status: RESOLVED FIXED
: fixed1.8
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: unspecified
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: Karsten Düsterloh
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-08 12:37 PST by Karsten Düsterloh
Modified: 2005-12-22 05:37 PST (History)
3 users (show)
iann_bugzilla: blocking‑seamonkey1.0b+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screenshot of problem (6.41 KB, image/png)
2005-12-08 12:40 PST, Karsten Düsterloh
no flags Details
make the throbber button square transparent in Classic (907 bytes, patch)
2005-12-08 15:46 PST, Karsten Düsterloh
kairo: review+
neil: superreview+
kairo: approval‑seamonkey1.0+
Details | Diff | Splinter Review

Description Karsten Düsterloh 2005-12-08 12:37:18 PST
The new SeaMonkey throbber is surrounded by grey square in Classic theme in recent (branch) builds (see attached screenshot). Windows (branch) builds are okay.
Comment 1 Karsten Düsterloh 2005-12-08 12:40:02 PST
Created attachment 205322 [details]
screenshot of problem
Comment 2 Robert Kaiser 2005-12-08 15:07:32 PST
Ouch...
Somehow we seems to get some background color into the throbber here, as the image itself is transparent. Unfortunately I don't have a mac box around here to try a fix, though I'd really like to come up with one... Could you try to hack communicator/brand.css in a way that the #navigator-throbber box has backgound-color:transparent or something similar?
Comment 3 Karsten Düsterloh 2005-12-08 15:46:51 PST
Created attachment 205347 [details] [diff] [review]
make the throbber button square transparent in Classic

This patch makes the throbber button background transparent.
Comment 4 Robert Kaiser 2005-12-08 16:01:03 PST
Comment on attachment 205347 [details] [diff] [review]
make the throbber button square transparent in Classic

r=me given this works in the described cases (which I can't test unfortunately), it's doing the same as modern already has...
Comment 5 Eyal Rozenberg 2005-12-09 00:12:34 PST
BTW, why doesn't the throbber in classic theme has a visible square button edge (visible on mouseover, I mean)? A flat, round-seeming throbber is kind of annoying IMHO.
Comment 6 neil@parkwaycc.co.uk 2005-12-09 01:33:18 PST
Comment on attachment 205347 [details] [diff] [review]
make the throbber button square transparent in Classic

sr=me given that two people have tried it (e.g. Mnyromyr and stefanh).
Comment 7 Ian Neal 2005-12-09 06:36:46 PST
Just to confirm, this patch also fixes it for me on Windows XP.
Comment 8 Robert Kaiser 2005-12-09 08:03:54 PST
Comment on attachment 205347 [details] [diff] [review]
make the throbber button square transparent in Classic

a+ per talk in #seamonkey channel :)
Comment 9 Stefan [:stefanh] 2005-12-09 09:47:40 PST
(In reply to comment #6)
> (From update of attachment 205347 [details] [diff] [review] [edit])
> sr=me given that two people have tried it (e.g. Mnyromyr and stefanh).
> 

Yeah, this fixes the issue with the grey square. My only complaint is that since the throbber is of such low quality (heavily compressed) and the toolbar's background is light the tail is pretty much invisible. I do think that the grey square should go, so this is the right fix. But, can we produce a throbber of better quality?
Comment 10 Karsten Düsterloh 2005-12-09 12:36:01 PST
Eyal, Stefan: Please file new bugs for other enhancements that are not part of the regression being fixed here. (Even though I think that a button hover rectangle around the throbber is really WONTFIX.)
Comment 11 Karsten Düsterloh 2005-12-09 12:46:03 PST
Checked in on trunk and branch.
Comment 12 Karsten Düsterloh 2005-12-22 05:37:06 PST
Checked in on MOZILLA_1_8_0_BRANCH.

Note You need to log in before you can comment on or make changes to this bug.