Report Broken Websites doesn't work - msg No SysID entered

NEW
Assigned to

Status

Webtools Graveyard
Reporter
--
major
12 years ago
2 years ago

People

(Reporter: Yves Goergen, Assigned: raccettura)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5

I entered a message into the Broken Website Reporter and as I wanted to submit it, it gave me the error message "No SysID entered". No data was submitted.

Reproducible: Always

Steps to Reproduce:
1. Use the Broken Website Report as it's intended

Actual Results:  
Error message "No SysID entered"

Expected Results:  
well, that it works
Assignee: nobody → robert
Component: General → Reporter
Product: Firefox → Webtools
QA Contact: general → web-service
Version: unspecified → other
(Assignee)

Comment 1

12 years ago
Reporter:

go to:
about:config

and search for the key:
extensions.reporter.sysid

Let me know what the value is by email (click on my name above this comment).
(Assignee)

Comment 2

12 years ago
Pressed commit to early: The value is random, and doesn't identify you in any way (it just says your an existing user rather than someone who never used the system before). I just don't like seeing any sort of a token, no matter how insignificant  posted on bugzilla, and so people don't copy/paste your token and skew report stats if we compare per unique user.
(Reporter)

Comment 3

12 years ago
Thanks for the support, Robert.

That key didn't exist in my Firefox, so I created it as an empty string. Then I tried to re-submit the actual web page report and this time it worked. Now the key was set to a nonempty value.

Looks like the reporter can't create a key but only set a value if the key exists, even if it's empty.
(Assignee)

Comment 4

12 years ago
It does create the key (as it does for everyone else), but for some reason (which I don't know) it didn't for you.

I'll leave this open for a while to see if we get any duplicates.
Robert,

On our forum tonight we also received another mention of this same problem:
http://www.mozbrowser.nl/forum/viewtopic.php?p=40308

I replied to the user that he should create this key using about:config and just wanted to let you know that there has been another occurence of this problem.

Could you in the extension's code specifically check whether this key has been created ? If it has not been created you could alert the user and tell how he/she can do this manually. Of course you want the extension to be able to do this, but it is nicer when the extension could catch situations like these than when users wonder what went wrong and ask for more details in forums, Bugzilla or using e-mail.
(Assignee)

Comment 6

12 years ago
It should be happening automatically.  Why it's taking that extra push, I don't know.

I'll try and look into it more, and see if I can reproduce it, though likely not until Jan sometime.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Now the person has tried the workaround (create the value extensions.reporter.sysid manually), but still no luck with the extension. He keeps getting the same error message.

I did not expect you to look into it immediately. I just wanted to mention that there's been another occurence. It would be nice if you can find what causes this.
(Assignee)

Comment 8

12 years ago
*** Bug 321906 has been marked as a duplicate of this bug. ***

Comment 9

12 years ago
Any news on fix for this yet?

Comment 10

12 years ago
"no sysid found" attempting to report https://www.hotel-paris-france.biz/

extensions.reporter.sysid not found in about:config 
for minefield Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060508 Minefield/3.0a1
Severity: normal → major
Summary: Report Broken Websites doesn't work → Report Broken Websites doesn't work - msg No SysID entered

Comment 11

12 years ago
Got this error just now trying to report a password-protected site http://www.pureprofile.com.au/member/account/

The following may be relevant..
This is the second time I've used this Report Broken Website feature.  The first time I was asked to create some sort of ID on the 2nd page of Report Broken Website, but I cancelled out of it & didn't submit the report.  Maybe that broke it?

Karen

Comment 12

10 years ago
Invalid SysID , when reporting http://www.bickertonskoda.co.uk/ , this is in version Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Comment 13

10 years ago
I've had the same problem, while the extensions.reporter.sysid did exist in my installation. I removed the value (<empty>) and that solved the problem here. As is written above, I can remember cancelling a report once, so that may be the culprit here.
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.