Firefox crash when selected file to upload via webform

RESOLVED DUPLICATE of bug 310137

Status

()

Core
Widget: Gtk
--
critical
RESOLVED DUPLICATE of bug 310137
13 years ago
5 years ago

People

(Reporter: Ilya Voyager Schurov, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

When I try to upload the file using any webform (i.e. in webmail or bugzilla "Create attachment"), Firefox crashes after closing "Select file" dialog. File name/content/type doesn't matter. Bug is reproducible in -safe-mode.

Reproducible: Always

Steps to Reproduce:
1. Open any web-form with upload field
2. Click "Browse" button in the form
3. Select any file
4. Click "OK"

Actual Results:  
Firefox crashes

Expected Results:  
Firefox continues working
(Reporter)

Comment 1

13 years ago
Some TB incidents:

TB12779944K
TB12780758M

Sometimes one should wait a couple of second after selecting the file before crash.
(Reporter)

Comment 2

13 years ago
Strange... I've filed this bugreport and it doesn't reproduces anymore... Guest effect? :)

Talkback says it can't find my incidents but I did have sent them... Very strange.
(In reply to comment #2)

> Talkback says it can't find my incidents but I did have sent them... Very
> strange.
>

Wait a few hours 

Comment 4

13 years ago
Hrm... those talkback reports look a bit out of whack. Can you uninstall and then reinstall with talkback to give this another try?

Comment 5

13 years ago
Incident ID: 12779944 
Stack Signature libgtk-x11-2.0.so.0 + 0x1f3ae3 (0x00742ae3) 5e3e7ea8 
Product ID Firefox15 
Build ID 2005111116 
Trigger Time 2005-12-09 08:59:53.0 
Platform LinuxIntel 
Operating System Linux 2.6.10-1.771_FC2.stk16 
Module libgtk-x11-2.0.so.0 + (001f3ae3) 
URL visited  
User Comments I've just choosed the file I wish to upload via webform. 
Since Last Crash 0 sec 
Total Uptime 32 sec 
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11) 
Source File, Line No. N/A 
Stack Trace  

libgtk-x11-2.0.so.0 + 0x1f3ae3 (0x00742ae3)
libglib-2.0.so.0 + 0x268ac (0x002248ac)
libglib-2.0.so.0 + 0x23e4a (0x00221e4a)
libglib-2.0.so.0 + 0x24f28 (0x00222f28)
libglib-2.0.so.0 + 0x25260 (0x00223260)
libglib-2.0.so.0 + 0x258a3 (0x002238a3)
libgtk-x11-2.0.so.0 + 0x10f923 (0x0065e923)
nsAppShell::Run()  [/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/widget/src/gtk2/nsAppShell.cpp, line 141]
nsAppStartup::Run()  [/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 151]
XRE_main()  [/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/toolkit/xre/nsAppRunner.cpp, line 2315]
main()  [/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/browser/app/nsBrowserApp.cpp, line 62]
libc.so.6 + 0x14ad4 (0x00cc9ad4)
Component: General → Widget: Gtk
Keywords: crash
Product: Firefox → Core
QA Contact: general → gtk
Whiteboard: DUPEME
Version: unspecified → 1.8 Branch

Comment 6

13 years ago
what versioni of gtk2 do you have?  Are you using "typedown" in the filepicker (hit keys and it goes to the file you type)?

see bug 310137
(Reporter)

Comment 7

13 years ago
Thanks, Andrew. This is a dupe of #310137.

*** This bug has been marked as a duplicate of 310137 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.