Closed Bug 319730 Opened 14 years ago Closed 14 years ago

No events found if a string typed into the search bar contains upper-case letters

Categories

(Calendar :: General, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla.i.sekler, Assigned: jminta)

Details

Attachments

(2 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051130 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051206 Mozilla Sunbird/0.3a1+

If a calendar contains an $Event (f.e. "Dinner"), searching for $Event ("Dinner) using the Search Bar shows no matches, while searching for $event ("dinner") finds and displays the event. 

Reproducible: Always

Steps to Reproduce:
1. Type a string matching an existing event, that contains upper-case letters, into the Search Bar.
Actual Results:  
no matches are found

Expected Results:  
the matching event should be display in the list, the search funktion shouldn't be case-sensitive.

Reproduced also with the official win32 nightly build from 2005-12-08, not OS-dependant.
Confirmed.  Patch coming as soon as cvs is back up after the server move.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attached patch use toLowerCase (obsolete) — Splinter Review
We change the event's properties to lower case, but not the search text.  This patch makes both user lower-case only, effectively making the search box case-insensitive.
Assignee: mostafah → jminta
Attachment #205444 - Flags: first-review?(mvl)
Comment on attachment 205444 [details] [diff] [review]
use toLowerCase

I don't know how long .toLowerCase() takes, but it seems to be an obvious optimization to do it once, instead of 5*n (n=number of events)
Attachment #205444 - Flags: first-review?(mvl) → first-review-
Attached patch fasterSplinter Review
Attachment #205444 - Attachment is obsolete: true
Attachment #205480 - Flags: first-review?(mvl)
Comment on attachment 205480 [details] [diff] [review]
faster

r=mvl
Attachment #205480 - Flags: first-review?(mvl) → first-review+
patch checked in
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.