JS error backtrace would be greatly appreciated

RESOLVED DUPLICATE of bug 125612

Status

--
enhancement
RESOLVED DUPLICATE of bug 125612
13 years ago
2 years ago

People

(Reporter: lisandro, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-AR; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-AR; rv:1.8) Gecko/20051111 Firefox/1.5

Often enough, a common JS library function yields an error that could be origined by many different other functions, so it would be a great help to know the function call stack for the malformed thread.
In fact, it's a fine feature from Opera browser that I wish you adopt. Take a look at this Opera's JS Console error report:

-------------------

Pegni Pulcu - Backoffice Administrador
http://www.latdev.com.ar/pegni/interoffice/admin_jerarquias.php
Event thread: load
Error:
name: TypeError
message: Statement on line 253: Could not convert undefined or null to object
Backtrace:
  Line 253 of linked script http://www.latdev.com.ar/pegni/scripts/engine_lib.js
    return iframe.document.frames[iframe.id].document;
  Line 112 of linked script http://www.latdev.com.ar/pegni/scripts/engine_ctl_radio_group_list.js
    this.oFrameDoc = getFrameDoc(this.oFrame);
  Line 447 of linked script http://www.latdev.com.ar/pegni/scripts/engine_lib.js
    aDeferredInits[k].init();
  Line 15 of inline#2 script in http://www.latdev.com.ar/pegni/interoffice/admin_jerarquias.php
    doDeferredInits();
  Line 1 of  script 
    initDocument();
  At unknown location
    [statement source code not available]


Reproducible: Always

Steps to Reproduce:

Actual Results:  
Debugging is dificult when you have a complex JS framework.

Expected Results:  
Tracing where the JS error came from.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 125612 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.