:before and :after pseudo-elements do not display on img and br elements

RESOLVED DUPLICATE of bug 245633

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 245633
12 years ago
12 years ago

People

(Reporter: Colin Snover, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

40.72 KB, application/xhtml+xml
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

:before and :after pseudo-elements do not display on <img /> and <br /> elements. All other elements that I have tried properly display :before and :after content.

Reproducible: Always

Steps to Reproduce:
1. Load a page with a :before or :after pseudo-element on an <img> or <br /> tag.
Actual Results:  
No content was added before or after the affected tag.

Expected Results:  
:before and :after content should have been added.

See the testcase for more information.
(Reporter)

Comment 1

12 years ago
Created attachment 205527 [details]
Testcase

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 245633 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.