In XUL overlays document.styleSheets[].title is empty when the XUL cache is enabled

RESOLVED FIXED

Status

()

--
minor
RESOLVED FIXED
13 years ago
10 years ago

People

(Reporter: smrank, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051211 Firefox/1.5
Plus same date's trunk build.

When the XUL cache is enabled, accessing document.styleSheets[].title from within a XUL overlay returns the correct stylesheet title the first time and is empty every time after. When the XUL cache is disabled, document.styleSheets[].title returns the correct title every time. I'm not sure if this is by design but I'm assuming the XUL cache is supposed to be invisible.
(Reporter)

Comment 1

13 years ago
Created attachment 205613 [details]
Testcase (apply as an overlay to demonstrate bug)
(Reporter)

Comment 2

13 years ago
Comment on attachment 205613 [details]
Testcase (apply as an overlay to demonstrate bug)

When the XUL cache is disabled the "testcase" returns the following every time:

Global 1
Global 2
Global 3

When the XUL cache is enabled it returns the previous message the first time and is blank on all successive loads.
(Reporter)

Updated

13 years ago
Attachment #205613 - Attachment description: Overlay file that demonstrates the problem → Testcase (apply as an overlay to demonstrate bug)

Updated

13 years ago
Keywords: testcase

Comment 3

13 years ago
I can confirm this with TB 1.5 release on Win2k: my addon's stylesheet got loaded fine, but its title was missing arbitrarily once in while. (I manipulate styles by script and grab the stylesheet by title - which didn't work, obviously. :( )
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

12 years ago
Fixed in bug 319654.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Depends on: 319654
Flags: in-testsuite?
Resolution: --- → FIXED

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.