Closed Bug 320196 Opened 15 years ago Closed 14 years ago

{inc} Bolded links move when I (right) click on them.

Categories

(Core :: Layout, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: chammaht, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5

This problem did not exist with the FF 1.0.x series.  Starting with the 1.5 RC builds (that I've tried) as well as the final FF 1.5 release the bold text of links (that are contained in the URI given to demonstrate this problem) exibit a problem.  The message board's thread title links are bold for recent threads.  When clicked on the links move to the right a little.  This does not happen with non-bolded links in the message board.

Reproducible: Always

Steps to Reproduce:
1.  Go to the given URI
2.  Right click on a bolded thread link
Actual Results:  
link moves rightward by a few pixels

Expected Results:  
link should not move
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5 ID:2005111116
I see this too.
It has not always been like this.
The behaviour changed somewhere between 11-Jul-2004 and 18-Jul-2004.
Needs a minimal testcase.
Blocks: 261196
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk
Why is nobody working on this?
Bug occurs in SeaMonkey 2006120701 (pre reflow branch) on Linux.
(at the URL, try the "Forum Feedback" link for example)
Bug does not occur in SeaMonkey 2006120801 (post reflow branch) on Linux.
Fixed by bug 300030 it seems, at least on Linux.
OS: Windows XP → All
Summary: Probably a render engine (gecko) problem. Bolded links move when I (right) click on them. → {inc} Bolded links move when I (right) click on them.
Weirdness observed with:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120606 Minefield/3.0a (pre-reflow branch)
(Clicking on bold "Forum Feedback" link moves it slightly to the right)

No weirdness observed with:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120804 Minefield/3.0a1 (post-reflow branch)
(Clicking on bold "Forum Feedback" link does not change its placement)

Concur with comment 5

-->RESOLVED FIXED 

300030
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Depends on: reflow-refactor
Resolution: --- → FIXED
This bug is NOT entirely fixed (at least on Win32). Here's a new way to reproduce:
1.) Go to the RWT forum link given above and click the "News and Views" link
2.) Right click on the bolded "New TPC-H 10,000GB submission." link
3.) Text shifts slightly to the left now instead of horribly to the right pre-reflow landing.

Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061210 Minefield/3.0a1
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
I don't see any movement of the links you indicate.
A testcase would be very helpful.
OK, I swear it was doing it this morning, but now it isn't. I quit :P
Status: NEW → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → FIXED
Included is a testcase in case people have doubts:

<html>
<head>
<style type="text/css">
TD {
	color: #003366;
	font-size: 12px;
	font-family: Arial, Helvetica, sans-serif;
}

.lrodd {
  	margin : 3% 0% 0% 1%;
   	background-color : White;
	font-size: 11px;
	color : #000000;
	font : Arial, Helvetica, sans-serif;
	vertical-align : middle;
}

TD.lrodd  A:link {
  	margin : 3% 0% 0% 1%;
   	background-color : White;
	font-size: 11px;
	color: #0000AA;
	font : Arial, Helvetica, sans-serif;
	vertical-align : middle;
	text-decoration: none;
}

.lroddhi  {
  	margin : 3% 0% 0% 1%;
   	background-color : White;
	font-size: 11px;
	color : #000000;
	font : Arial, Helvetica, sans-serif;
	font-weight : bold;
	vertical-align : middle;
}

TD.lroddhi  A:link {
  	margin : 3% 0% 0% 1%;
   	background-color : White;
	font-size: 11px;
	color: #0000AA;
	font : Arial, Helvetica, sans-serif;
	font-weight : bold;
	vertical-align : middle;
	text-decoration: none;
}

.lrevenhi  {
	margin : 3% 0% 0% 1%;
   	background-color : #E3E3E3;
	font-size: 11px;
	color :#000000;
	font : Arial, Helvetica, sans-serif;
	font-weight : bold;
	vertical-align : middle;
}

TD.lrevenhi A:link {
  	margin : 3% 0% 0% 1%;
   	background-color : #E3E3E3;
	font-size: 11px;
	color : #0000AA;
	font : Arial, Helvetica, sans-serif;
	font-weight : bold;
	vertical-align : middle;
	text-decoration: none;
}
</style>
</head>
<body>
<table width="100%" bgcolor="white" border="0" cellpadding="0" cellspacing="0">
<tr>
	<td class="lrodd" valign="middle" height="17">&nbsp;&nbsp;&nbsp;<a href="/link">root (not bolded)</a>&nbsp;</td>
	<td class="lrodd" valign="middle" height="17" nowrap>&nbsp;</td>
	<td class="lrodd" valign="middle" height="17" nowrap>&nbsp;</td>
</tr>
<tr>
	<td class="lrevenhi" valign="middle" height="17"><b>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<a href="/link">subnode</a>&nbsp;</b></td>
	<td class="lrevenhi" valign="middle" height="17" nowrap>&nbsp;</td>
	<td class="lrevenhi" valign="middle" height="17" nowrap><b>&nbsp;</b></td>
</tr>
<tr>
	<td class="lroddhi" valign="middle" height="17"><b>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<a href="/link">subsubnode</a>&nbsp;</b></td>
	<td class="lroddhi" valign="middle" height="17" nowrap>&nbsp;</td>
	<td class="lroddhi" valign="middle" height="17" nowrap><b>&nbsp;</b></td>
</tr>
</table>
</body>
</html>
(In reply to comment #10)
chammaht@yahoo.com - are you still seeing the problem with a build that is
dated 2006-12-09 or later?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061216 Minefield/3.0a1
I see the problem in branch but not in trunk.
The problem is not present in the latest build.  The reflow refactoring work seems to have solved it, along with quashing numerous other bugs.

Case closed.
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.