If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Installation isn't complete until installer runs as root

VERIFIED DUPLICATE of bug 311480

Status

()

Firefox
Installer
--
major
VERIFIED DUPLICATE of bug 311480
12 years ago
12 years ago

People

(Reporter: Miles O'Neal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

After running the installer, one cannot run firefox 1.5 correctly until it has been run as root. Otherwise it complains about not being able to install certain chrome components.  We have about 45 Linux users, many of whom are not that Linux savvy.  They just need things to work.  They shouldn't have to slog through running the browser as root.  Among other things it wants to add a profile-- but root doesn't have acces son their machines to their NFS-mounted home directories, so thwy have to change the directory to /tmp .  It's hard enough herding a bunch of engoineers through this, I can't imagine trying to deal with your average consumer.

The installer should handle *all* the installation issues.

Reproducible: Always

Steps to Reproduce:
1. Type "sudo path_to_1.5_installer"
2. Type "firecox"
3. Watch it whine.

Actual Results:  
I don't have the exact message in front of me, but there are at least three popup panels complaining about not being able to install some chrome component.

Expected Results:  
It should just work.

Is this where I type "you suck"?

8^)

Just kididng.  I love firefox.  But I need to be able to hand my users a simple script that just runs the installer and lets them get on their way.

This may seem minor, but it has already taken two hours of my day, and not everyone is upgraded yet.  It's worsened because it behaves differetly in different environments (sometimes you can't "sudo firefox" - you have to actually login as root.  Since this is a major, production environment, we can't just hand out full root privs to everyone.

Comment 1

12 years ago
1) the installer is no longer the recommended install mechanism, the tarballs are recommended
2) This was release-noted, it is a duplicate of bug 311480.

*** This bug has been marked as a duplicate of 311480 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.