If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot run regxpcom anymore on Sparc/Solaris (dynamic linking not supported)

RESOLVED FIXED

Status

()

Core
XPCOM
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: InvisibleSmiley, Unassigned)

Tracking

({fixed1.8.0.1, fixed1.8.1})

Trunk
Sun
Solaris
fixed1.8.0.1, fixed1.8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051206 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051206 SeaMonkey/1.5a

Sparc/Solaris 5.8, building from source, Compiler: cc: Sun WorkShop 6 update 2 C 5.3 Patch 111679-11 2003/04/02

With Firefox 1.5 and current SeaMonkey nightly builds from trunk, I cannot run regxpcom any more. It used to work with all Firefox 1.x versions and older Mozilla versions (unfortunately, I cannot tell exactly when it broke).

Reproducible: Always

Steps to Reproduce:
1. cd to application directory
2. run ./run-mozilla.sh ./regxpcom

Actual Results:  
Output:
XPCOM glue dynamic linking is not implemented on this platform!Can not initialize XPCOM Glue
Can not aquire component registrar


Expected Results:  
It should work
(Reporter)

Updated

12 years ago
OS: Other → Solaris
Hardware: Other → Sun

Comment 1

12 years ago
http://lxr.mozilla.org/mozilla/source/xpcom/glue/standalone/Makefile.in#71

You either need to add Solaris to one of the existing conditions (dlopen?) or write a dynamic linking stub for this platform (use of NSPR is not allowed in this code due to the way the standalone glue needs to work).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

12 years ago
Assignee: dougt → nobody
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> http://lxr.mozilla.org/mozilla/source/xpcom/glue/standalone/Makefile.in#71
> 
> You either need to add Solaris to one of the existing conditions (dlopen?) or
> write a dynamic linking stub for this platform (use of NSPR is not allowed in
> this code due to the way the standalone glue needs to work).

From config/autoconf.mk I can tell that OS_ARCH is SunOS here. Adding this to the list in line 64 seems to do the trick (after a recompile/reinstall, regxpcom is working again).

If someone can verify this I'd suggest checking this in on trunk and all relevant branches (SM 1.0, FF 1.5, TB 1.5; maybe more) ASAP.

Comment 3

12 years ago
Please provide a patch.
(Reporter)

Comment 4

12 years ago
Created attachment 205974 [details] [diff] [review]
SeaMonkey trunk patch
(Reporter)

Comment 5

12 years ago
Created attachment 205975 [details] [diff] [review]
Firefox 1.5 patch
(Reporter)

Comment 6

12 years ago
Don't know whether SeaMonkey trunk and Firefox trunk are the same; maybe FF trunk needs yet another patch.

Thunderbird should also be taken care of, but I have no source for the 1.5 branch.

There may be even more branches needing the fix (Sunbird?) but I don't know about that either.

Comment 7

12 years ago
One patch is sufficient, it will end up on three trees (trunk, 1.8, and 1.8.0).

Updated

12 years ago
Attachment #205974 - Flags: review?(pete.zha)

Comment 8

12 years ago
Comment on attachment 205974 [details] [diff] [review]
SeaMonkey trunk patch

>--- xpcom/glue/standalone/Makefile	Thu Dec 15 16:48:50 2005
>+++ xpcom/glue/standalone/Makefile.new	Thu Dec 15 16:44:37 2005
You need to modify Makefile.in instead of Makefile.
(Reporter)

Comment 9

12 years ago
Created attachment 206072 [details] [diff] [review]
SeaMonkey trunk Makefile.in patch
Attachment #205974 - Attachment is obsolete: true
Attachment #205974 - Flags: review?(pete.zha)
(Reporter)

Comment 10

12 years ago
Created attachment 206073 [details] [diff] [review]
Firefox 1.5 Makefile.in patch
Attachment #205975 - Attachment is obsolete: true

Comment 11

12 years ago
Comment on attachment 206072 [details] [diff] [review]
SeaMonkey trunk Makefile.in patch

r=pete
Attachment #206072 - Flags: review+

Comment 12

12 years ago
Comment on attachment 206073 [details] [diff] [review]
Firefox 1.5 Makefile.in patch

r=pete if appropriate
Attachment #206073 - Flags: review+

Comment 13

12 years ago
Fixed on trunk. (I put SunOS in it's proper alphabetical order)
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Attachment #206072 - Flags: approval1.8.1?
Attachment #206072 - Flags: approval1.8.0.1?

Comment 14

12 years ago
From Comment 13 - can we get a patch with the proper ordering?  Thanks!
(Reporter)

Comment 15

12 years ago
Created attachment 206374 [details] [diff] [review]
Firefox 1.5 patch with proper ordering

Not checking Obsoletes since other patch has review
(Reporter)

Comment 16

12 years ago
Created attachment 206375 [details] [diff] [review]
SeaMonkey trunk patch with proper ordering

Not checking Obsoletes since other patch has review
Comment on attachment 206375 [details] [diff] [review]
SeaMonkey trunk patch with proper ordering

a=dveditz for drivers
Attachment #206375 - Flags: approval1.8.1+
Attachment #206375 - Flags: approval1.8.0.1+

Updated

12 years ago
Attachment #206072 - Flags: approval1.8.1?
Attachment #206072 - Flags: approval1.8.0.1?

Comment 18

12 years ago
Landed on 1.8branch and 1.8.0branch.
Keywords: fixed1.8.0.1, fixed1.8.1
You need to log in before you can comment on or make changes to this bug.