Closed Bug 320409 Opened 14 years ago Closed 13 years ago

Unresponsive Script

Categories

(Firefox :: General, defect, critical)

PowerPC
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 335058

People

(Reporter: len, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Camino/1.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Camino/1.0b1

Cannot use Firefox 1.5 at all on mm Mac System 0S X V1.4 due to a page opening and the warning message...Unresponsive Script...a script on this page may be busy or it may have stopped.....Cannot cancel this or continue and must force quit application.

I have my.yahoo.com as my default web page. I was able to get into Firefox preferences and change the default page and then restarted and was able to load the other page. I thought it might be Java or a Java Script causing the issue so I went back to the preferences and unchecked the options to enable Java and Java Script thinking this might be the issue, but I ended up with the same problem, the Unresponsive Script.  I have also had this same issue at Pay Pal so I think it is not a Yahoo issue.

Reproducible: Always

Steps to Reproduce:
1. See above...happens every time going to my.yahoo.com and must force quit to get out of this loop
2.
3.




Should have loaded this page without any problems
Are you using any extensions? Can't you click the "Stop Script" button when this dialog appears?
Found the same problem in Pay Pal just now.  When you go to Pay Pal to print a shipping label from the USPS which uses a Java Applet, you will get this Unresponsive Script message.  Interesting however if you go to print a UPS shippnig label they must use a different system and there is no problem.

I have a strong feeling it has to do with how Firefox 1.5 handles Java and these java applets.
I have deleted all extensions thinking one might be the issue but it still comes up and you cannot cancel it or get out of that window unless you Force Quit the application.

I cannot use Firefox anymore and have switched over to Camino.  Lacks some of the bells and whistles, but seems to be able to print the US Postal labels, etc. without a problem.

Yesterday I even upgraded my IMac system software thinking that might have been part of the problem and successfully installed the latest version Tiger, system 1.4
You're not the only person who's having this problem at My Yahoo; see 
bug 320020 comment 2.

The problem you're having at My Yahoo and the problem you're having at PayPal might not be related, even though they both cause the same warning dialog to be dispalyed.  Any page that has JavaScript that runs for a long time will cause the dialog to be displayed, and AFAIK My Yahoo doesn't use Java.
Bug started occuring when I upgraded to Firefox 1.5.  I can contiue to use Browser after i click on  "Stop Script".   John
dupe of bug 335058 ?

workaround: you can increase the value of the pref dom.max_script_run_time , see
http://kb.mozillazine.org/About:config
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 335058
You need to log in before you can comment on or make changes to this bug.