New self-created accounts dont get regexp group memberships

RESOLVED FIXED in Bugzilla 2.22

Status

()

Bugzilla
User Accounts
P1
critical
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Joel Peshkin, Assigned: Joel Peshkin)

Tracking

2.21
Bugzilla 2.22
Bug Flags:
approval +
blocking2.22 +

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

12 years ago
The insert_new_user function in User.pm should call     
    $user->derive_regexp_groups;

and it doesn't.

Updated

12 years ago
Severity: blocker → critical
Flags: blocking2.22+
Priority: -- → P1
(Assignee)

Comment 1

12 years ago
Created attachment 206086 [details] [diff] [review]
Patch insert_new_user to derive groups as well
Attachment #206086 - Flags: review?(LpSolit)

Updated

12 years ago
Assignee: user-accounts → bugreport
(Assignee)

Comment 2

12 years ago
Created attachment 206261 [details] [diff] [review]
v2 - remove extra derive from editusers
Attachment #206086 - Attachment is obsolete: true
Attachment #206086 - Flags: review?(LpSolit)
(Assignee)

Updated

12 years ago
Attachment #206261 - Attachment description: v2 - remove extra drive from editusers → v2 - remove extra derive from editusers
Attachment #206261 - Flags: review?(LpSolit)

Comment 3

12 years ago
Comment on attachment 206261 [details] [diff] [review]
v2 - remove extra derive from editusers

works fine. r=LpSolit
Attachment #206261 - Flags: review?(LpSolit) → review+

Updated

12 years ago
Status: NEW → ASSIGNED
Flags: approval?
Flags: approval? → approval+

Comment 4

12 years ago
Checking in createaccount.cgi;
/cvsroot/mozilla/webtools/bugzilla/createaccount.cgi,v  <--  createaccount.cgi
new revision: 1.46; previous revision: 1.45
done
Checking in editusers.cgi;
/cvsroot/mozilla/webtools/bugzilla/editusers.cgi,v  <--  editusers.cgi
new revision: 1.111; previous revision: 1.110
done
Checking in Bugzilla/User.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/User.pm,v  <--  User.pm
new revision: 1.99; previous revision: 1.98
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.