Spellchecking menu checkboxes don't work

RESOLVED FIXED

Status

()

Firefox
Bookmarks & History
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: mossop, Assigned: mossop)

Tracking

({fixed1.8.1})

Trunk
fixed1.8.1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

13 years ago
The spellchecking UI introduced in bug 302050 has problems on the menu items that should appear to be checked.

Patch coming.
(Assignee)

Comment 1

13 years ago
Created attachment 205995 [details] [diff] [review]
Make menuitems checkbox type

This makes the menu items for enabling spell checking and the dictionary list checkbox type.

Ben reviewed the original frontend patch so I guess this is his territory.
Attachment #205995 - Flags: review?(bugs)
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED

Comment 2

13 years ago
Thanks for finding this.

You'll also have to fix the "enabled" menuitem in
toolkit/content/widgets/textbox.xml in input-box-contextmenu
This is the context menu used by chrome.
(Assignee)

Updated

13 years ago
Attachment #205995 - Attachment is obsolete: true
Attachment #205995 - Flags: review?(bugs)
(Assignee)

Comment 3

13 years ago
Created attachment 206005 [details] [diff] [review]
Makes context menu items checkboxes where appropriate

Thanks, missed that.

Added checkbox type to toolkit textbox context menu.
Attachment #206005 - Flags: review?(bugs)
(Assignee)

Updated

13 years ago
Blocks: 302050
(Assignee)

Comment 4

13 years ago
Comment on attachment 206005 [details] [diff] [review]
Makes context menu items checkboxes where appropriate

mconnor suggested that you could review this.
Attachment #206005 - Flags: review?(bugs) → review?(brettw)

Comment 5

13 years ago
*** Bug 325819 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
Comment on attachment 206005 [details] [diff] [review]
Makes context menu items checkboxes where appropriate

Looks good
Attachment #206005 - Flags: review?(brettw) → review+

Updated

13 years ago
Component: General → Places
mozilla/toolkit/content/widgets/textbox.xml; new revision: 1.28;
mozilla/toolkit/content/inlineSpellCheckUI.js; new revision: 1.2;
mozilla/browser/base/content/browser-context.inc; new revision: 1.17;
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED

Updated

13 years ago
Blocks: 329668

Comment 8

13 years ago
Comment on attachment 206005 [details] [diff] [review]
Makes context menu items checkboxes where appropriate

See bug 329668 for tracking the branch landing of the spellchecker.
Attachment #206005 - Flags: approval-branch-1.8.1?(bugs)
Comment on attachment 206005 [details] [diff] [review]
Makes context menu items checkboxes where appropriate

a=ben@mozilla.org
Attachment #206005 - Flags: approval-branch-1.8.1?(bugs) → approval-branch-1.8.1+

Updated

12 years ago
Keywords: fixed1.8.1
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: general → bookmarks
You need to log in before you can comment on or make changes to this bug.