ECDSA_SignDigestWithSeed and ECDSA_VerifyDigest should allow non-SHA-1 digest

RESOLVED DUPLICATE of bug 320583

Status

P1
enhancement
RESOLVED DUPLICATE of bug 320583
13 years ago
13 years ago

People

(Reporter: wtc, Assigned: wtc)

Tracking

3.11
3.11.1

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

13 years ago
If the digest is not a SHA-1 digest, ECDSA_SignDigestWithSeed
fails with the SEC_ERROR_INVALID_ARGS error.  We should
remove this check and make it work with any message digest
length.
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → 3.12
(Assignee)

Comment 1

13 years ago
This enhancement request also applies to ECDSA_VerifyDigest.
Summary: ECDSA_SignDigestWithSeed should allow non-SHA-1 digest → ECDSA_SignDigestWithSeed and ECDSA_VerifyDigest should allow non-SHA-1 digest
(Assignee)

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 320583 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

13 years ago
Target Milestone: 3.12 → 3.11.1
You need to log in before you can comment on or make changes to this bug.