Last Comment Bug 320623 - overflow="visible" doesn't work on <marker>
: overflow="visible" doesn't work on <marker>
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Robert Longson
: Hixie (not reading bugmail)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-17 00:50 PST by Jonathan Watt [:jwatt] (back in October - email directly if necessary)
Modified: 2006-01-12 09:40 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
merge overflow into style system for elements which support it (8.83 KB, patch)
2006-01-04 09:20 PST, Robert Longson
tor: review+
jst: superreview+
Details | Diff | Splinter Review

Description Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2005-12-17 00:50:02 PST
Although style="overflow:visible" works, overflow="visible" does not. It should: from http://www.w3.org/TR/SVG/attindex.html, overflow applies to PresentationAttributes-Viewports which includes PresentationAttributes-All which includes 'marker'.
Comment 1 Robert Longson 2006-01-04 09:20:28 PST
Created attachment 207505 [details] [diff] [review]
merge overflow into style system for elements which support it

I have tested this works with marker elements. 
Symbol elements seem to work without this fix in firefox 1.5 though I don't understand how.
For pattern it seems not to do anything on the trunk. Does clipping need implementing for pattern elements on the trunk? If so that's probably a separate fix anyway.
Comment 2 tor 2006-01-09 09:53:59 PST
Comment on attachment 207505 [details] [diff] [review]
merge overflow into style system for elements which support it

<symbol> works already because we do a full clone and replace <symbol> with <svg>.
Comment 3 Johnny Stenback (:jst, jst@mozilla.com) 2006-01-11 16:56:53 PST
Comment on attachment 207505 [details] [diff] [review]
merge overflow into style system for elements which support it

sr=jst
Comment 4 tor 2006-01-12 09:40:01 PST
Checked in for Robert.

Note You need to log in before you can comment on or make changes to this bug.