There must be away of turning compatibility mode on and off using HTTP

VERIFIED DUPLICATE of bug 31933

Status

()

P3
minor
VERIFIED DUPLICATE of bug 31933
19 years ago
19 years ago

People

(Reporter: webmaster, Assigned: rickg)

Tracking

({verifyme})

Trunk
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
There should be a way of using an HTTP header to turn compatibility mode on and 
off. At present it is triggered by transitional DTD, which is _bad_ - 
transitional dtd does not mean 'Break my pages please'.

The fact that transitional dtd triggers compatibility mode does not make those 
bugs less buggy. In fact, it is causing me major problems because the hacks that 
I use to workaround Netscape 4's bugs no longer work with Mozilla, and so I 
have annoying display glitches in Mozilla.

The most important thing is that since 'compatibility mode'=='bug mode' (every 
supposed compatibility mode feature is actually a bug), there must be a way to 
disable it.

I suggest a Compatibility-Mode HTTP header.
For the user ther should be a two-state (check marked) menu item in the View
menu that would both indicate the mode and let the user change it (temporarily)
if Mozilla has guessed wrong.

Comment 2

19 years ago
I agree with this bug, but I believe it duplicates bug 31933.

*** This bug has been marked as a duplicate of 31933 ***
Severity: critical → minor
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Hardware: PC → All
Resolution: --- → DUPLICATE
Keywords: verifyme

Comment 4

19 years ago
VERIFY dupe
Status: RESOLVED → VERIFIED
Bug 42525 is about being able to get standard layout for transitional documents. You 
may want to add your comments to that bug.
You need to log in before you can comment on or make changes to this bug.