An image map without the name attribute does not work

RESOLVED DUPLICATE of bug 207241

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 207241
13 years ago
13 years ago

People

(Reporter: Bartolome Sintes, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8) Gecko/20051111 Firefox/1.5

In a valid XHTML 1.0 document, if the map element does not have the name attribute, the image map does not work. In a XHTML 1.0 document this problem can be solved adding the name attribute, but if the document is a XHTML 1.1 document, if the name element is added the document becomes invalid.

Reproducible: Always

Steps to Reproduce:
1. Open the testcase http://www.cdlibre.org/prueba/mozilla_bugs/051220_image_map/051220_mozilla_bug_map_id_10.html
2. Reduce the size of the Firefox window in order to only see the image.
3. Click on the image
4. Notice that the link does not work
Actual Results:  
The link does not work, but the document is XHTML 1.0 valid.


I have added three other testcases:
* http://www.cdlibre.org/prueba/mozilla_bugs/051220_image_map/051220_mozilla_nobug_map_id_10.html
shows how to solve the problem adding the name attribute to the map element. The image map works and document is valid.

* http://www.cdlibre.org/prueba/mozilla_bugs/051220_image_map/051220_mozilla_bug_map_id_11.html
shows the problem in a valid XHTML 1.1 document. The image maps does not work.

* http://www.cdlibre.org/prueba/mozilla_bugs/051220_image_map/051220_mozilla_nobug_map_id_11.html
 shows how to solve the problem adding the name attribute to the map element, but the document becomes invalid. The image map works.

Comment 1

13 years ago
The documents are being sent with the text/html content type, so HTML rules apply.  

*** This bug has been marked as a duplicate of 207241 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.