Closed Bug 321023 Opened 14 years ago Closed 10 years ago

Right-clicking current tab focuses it, and left-clicking page then leaves focus on tab, doesn't focus page

Categories

(Firefox :: Tabbed Browser, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

()

VERIFIED FIXED
Firefox 3.6a1

People

(Reporter: ytpete, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: polish, verified1.9.1, Whiteboard: [fixed by bug 462289])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

This is confusing UI behavior:

Reproducible: Always

Steps to Reproduce:
1. Right-click the currently selected tab
   (notice that the tab gets a dotted focus rectangle)
2. Left-click on the page itself to close the menu

Actual Results:  
Tab remains focused. Attempting to scroll the page with arrow keys, etc. instead changes tabs.

Expected Results:  
Page has focus, since I just clicked on it.

There are at least two ways to fix this:

a) Only focus the current tab when LEFT-clicking. Today's behavior is confusing because right-clicking to get a context menu sometimes changes focus, and sometimes not (depending on which tab was right-clicked).
 
b) Fix bug 226525. If the second click isn't eaten, the page will be focused by it as expected.

Seems like (b) is preferrable...
Version: unspecified → 1.5 Branch
In reply to comment #0)
> There are at least two ways to fix this:
> 
> a) Only focus the current tab when LEFT-clicking. ...
> ... right-clicking to get a context menu sometimes changes focus, and
> sometimes not (depending on which tab was right-clicked).
> 
> b) Fix bug 226525. If the second click isn't eaten, the page will be focused by
> it as expected.
> 
> Seems like (b) is preferrable...

confirming - happens on trunk.
shouldn't this be marked depends on or dup of Bug 226525?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 1.5.0.x Branch → Trunk
Severity: normal → minor
Depends on: 226525
Summary: Right-clicking current tab focuses it, and left-clicking page then leaves focus there → Right-clicking current tab focuses it, and left-clicking page then leaves focus on tab, doesn't focus page
Depends on: 462289
mats, see this on linux?
Flags: blocking-firefox3.6?
Doesn't block release, but would be happy to see a fix since it's a nuisance.
Flags: blocking-firefox3.6? → blocking-firefox3.6-
Keywords: polish
WFM on Mac.  Wasn't this fixed by the patch in bug 462289?
WFM on Vista with Firefox 3.5.2, as well.
Fixed by the patch in bug 462289.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
does NOT work for me on XP, 3.5.3 and 3.7a1pre

page does not get focus.

to reproduce:
1. click in the url bar
2. right click anywhere on the tab strip to get the context menu
3. left click in a form on the page - it does not get focus

this is unique to the tab strip context menu. with other context menus it works fine.
(In reply to comment #7)
> this is unique to the tab strip context menu. with other context menus it works
> fine.

This is bug 226525, though. And it applies to other context menus, like the one for the location bar.
Keywords: verified1.9.1
Whiteboard: [fixed by bug 462289]
Target Milestone: --- → Firefox 3.6a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.