Closed Bug 321037 Opened 19 years ago Closed 19 years ago

Save a page, and it resubmits an action request

Categories

(Toolkit :: Downloads API, defect)

x86
All
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 115174

People

(Reporter: andrewjrvs, Unassigned)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; PeoplePal 3.0; .NET CLR 2.0.40607)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

We have been experiencing some problems on our companies Internet Banking Site with our firefox customers. When our customers attempt to save their conformation number by saving the conformation page, (IE "Save as" - HTML only) The transfer request is resubmitted to our servers. Thus causing a double transfer request in some cases. Firefox is the only browser we have experienced this problem with, and it is only with the "HTML only" type that received this problem. Our Site uses Cold fusion .CFM (note our Conformation number for our site is displayed on the same url as the request page IE I will make my request at http://example.com/request.cfm and my conformation will be displayed on http://example.com/request.cfm)

Reproducible: Always

Steps to Reproduce:
1.Submit the information for the request action on the site
2.wait for the conformation number to display
3.On the Firefox browser Click "File", "Save Page As", and select "Web Page, HTML only" as the File type to save as

Actual Results:  
In this case the requested transfer has posted twice. Another thing is the conformation number for the page, and the saved file does not match. The saved html file receives a new conformation number.

Expected Results:  
A single request, and a backup HTML copy of the conformation number.
Related to/duplicate of Core bug 115174?

*** This bug has been marked as a duplicate of 115174 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.