Back button (history) behaves different between https and http webserver

RESOLVED DUPLICATE of bug 215405

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 215405
12 years ago
10 years ago

People

(Reporter: Heiko Burghardt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051212 Fedora/1.5-0.fc4 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051212 Fedora/1.5-0.fc4 Firefox/1.5

The back button in Firefox 1.0.x and 1.5 behaves different between a http and a https server (offering the same webpage!).

On the http server you can scroll down on a page, click a link, going back and you return to the (scrolled) point on the previous page where you clicked the link. Using the https server (same content), clicking a link and going back returns to the top of the previous page. 

The problem appeared at our internal wiki software using large documents on a https webserver. So, I searched for a public available site for you to reproduce the problem...

Reproducible: Always

Steps to Reproduce:
Although the demo page is only existing in German you can use this for testing purposes:

Correct handling with a http server
1. use the url http://daily.sdinet.de/
2. scroll down and click a link
3. use the back button -> you get back to the scrolled page

Incorrect handling using the same page under https:
1. use the url https://daily.sdinet.de/
2. scroll down and click a link
3. use the back button -> you get back to the top of the page



Expected Results:  
I would expect the firefox behavior like on the http server.

This behavior could be reproduced under Windows and Linux

Comment 1

12 years ago
The difference is probably caused by a difference in caching: Firefox honors more methods of saying "don't cache this" when the server uses https.  Firefox also has a bug where if a page says "don't cache this", it doesn't remember the scroll position.

*** This bug has been marked as a duplicate of 215405 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.