instanceof results for "literal" functions changed in FF 1.5

RESOLVED DUPLICATE of bug 300079

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 300079
13 years ago
10 years ago

People

(Reporter: Thomas Blatter, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

578 bytes, application/vnd.mozilla.xul+xml
Details
581 bytes, text/html
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Not sure if this is a bug or a feature, fact is that instanceof for literal functions has changed in FF 1.5 in xul-windows/scripts (this does not affect html documents/scripts)

Using:

function iof(o,c){alert(o instanceof c)}

iof(function(){},Object) old yields "true" xul1.5 "false"
iof(function(){},Function) old yields "true" xul1.5 "false"

(old here is mozilla 1.7.12 - html & xul - or ff 1.5-html, xul1.5 is ff 1.5-xul)

Note that js console behaves like 1.5-html

Reproducible: Always

Steps to Reproduce:
1. load xul and / or html testcases
2. click "test instanceof" button
3. compare alerts between xul / html, resp. versions of moz / ff

Actual Results:  
As mentioned above

Expected Results:  
Same behaviour in ff-1.5-xul as everywhere else, literal functions are Object's as well as Function's even in xul...
(Reporter)

Comment 1

13 years ago
Created attachment 206607 [details]
Testcase xul
(Reporter)

Comment 2

13 years ago
Created attachment 206608 [details]
Testcase html

Comment 3

13 years ago
I can confirm the results that Thomas described. I don't think this is the JS Engine, but is XUL related. Moving there and confirming for now.
Component: JavaScript Engine → XP Toolkit/Widgets: XUL

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 300079 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: general → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.