Loading Gmail leaks six DOMWindows

RESOLVED FIXED

Status

()

Core
XML
--
major
RESOLVED FIXED
12 years ago
4 years ago

People

(Reporter: Jesse Ruderman, Assigned: dbaron)

Tracking

({mlk})

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
If I load Gmail and then quit Firefox, I see 6 DOMWindows leak.

Details that might or might not matter:
* I'm already logged in.  
* I load Gmail by clicking a bookmark on my toolbar that goes to https://mail.google.com/mail/ (not http).
* This is with a trunk debug build on Mac with dbaron's leak-detecting stuff.
* I disabled all of my extensions before testing.

dbaron says "It's possible this is bug 206520".
(Assignee)

Comment 1

12 years ago
GC_MARK_DEBUG shows that the problem is probably related to an XPCWrappedJS for an nsIOnReadyStateChangeHandler, which also suggests bug 206520.

Comment 2

12 years ago
Leaked outer window 2225978 at address 2225978.
Leaked inner window 1dd7928 (outer 2225978) at address 1dd7928.
... with URI "http://mail.google.com/mail/html/loading.html".
Leaked inner window 224cd98 (outer 2225978) at address 224cd98.
... with URI "http://mail.google.com/mail/?view=page&name=js&ver=c0d89211112a7d0e".
Leaked outer window 332bad8 at address 332bad8.
Leaked inner window 33250c8 (outer 332bad8) at address 33250c8.
... with URI "http://mail.google.com/mail/?view=page&name=hist1&ver=6e8ea81451e33c4f".
Leaked inner window 31acae0 (outer 332bad8) at address 31acae0.
... with URI "http://mail.google.com/mail/?&ik=c817c8b81b&search=spam&view=tl&start=0".
Leaked inner window 23dec58 (outer 332bad8) at address 23dec58.
... with URI "http://mail.google.com/mail/?view=page&name=hist1&ver=6e8ea81451e33c4f".
Summary:
Leaked 7 out of 64 DOM Windows
Leaked 0 out of 72 documents
Leaked 0 out of 17 docshells

also affects windows xp
(Assignee)

Comment 3

12 years ago
Output like that is not useful.  We already know.

Comment 4

12 years ago
*** Bug 337306 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

12 years ago
Fixed on trunk by checkin of bug 206520.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Updated

12 years ago
Assignee: xml → dbaron
(Reporter)

Comment 6

12 years ago
Btw, I think Gmail fixed this on their end.  I hadn't seen DOMWindow leaks (in trunk builds) when using Gmail for several days before bug 206520 was fixed.
odd, because I most definitely was. However, I'm not anymore since using a build with 206520 included.
You need to log in before you can comment on or make changes to this bug.