Cannot open a file upon click-open (.gz .zip .pdf etc) - Mozilla 1.7 can

RESOLVED DUPLICATE of bug 180672

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 180672
12 years ago
12 years ago

People

(Reporter: Joachim Otahal, Unassigned)

Tracking

1.8 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.7.11) Gecko/20050728
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051219 SeaMonkey/1.0b

Cannot open a file upon click-open (.zip .pdf etc) - Mozilla 1.7 can.
I have to save them with Seamonkey before I can open.
In Mail: nothing happens.
In Browser: "Unable to open C:\DOKUME~1\JOU\LOKALE~1\TEMP\sx3pv8r8.gz"
(or, other machine)
In Browser: Unable to open C:\DOKUME~1\SUPERV~1\LOKALE~1\TEMP\sx3pv8r8.gz
It strikes me that Seamonkey uses shortfilename here.

Both Mozilla 1.7 and Seamonkey are using the same profile.
Mozilla asks "what should i do with the file", I choose "open with winrar" -> working.


Reproducible: Always

Steps to Reproduce:
1. Open webpage with .zip or .pdf
2. click .zip/.pdf etc
3. Seamonkey says "C:\DOKUME~1\JOU\LOKALE~1\TEMP\sx3pv8r8.gz" - Mozilla opens to WinRAR.

Actual Results:  
Unable to open C:\DOKUME~1\JOU\LOKALE~1\TEMP\sx3pv8r8.gz
Messagebox...

Expected Results:  
Open file with WinRAR (or ask what to do).
Note that rightclick-save-the-file works.

Default Mozilla Theme, add on:
user agent switcher
adblock
"ssun" show smtp username
(For that i.-cannot-understand-it-still-is-htere https://bugzilla.mozilla.org/show_bug.cgi?id=202468 bug https://bugzilla.mozilla.org/show_bug.cgi?id=119609 - using three accounts with auth on one mail server with smtp)

For the last add-on: I didn't test whether it is still nessecary with seamonkey, didn't get that far.

Comment 1

12 years ago
Does removing everything in %temp% solve this?
(Reporter)

Comment 2

12 years ago
emptying %temp% does not help.
Trying a different user profile does not help.
The filename seamonkey displays is random, just the extension is the expected file.
Apply to ftp and http downloads.
Environment variables (on work machine):
TEMP=C:\DOKUME~1\SUPERV~1\LOKALE~1\Temp
TMP=C:\DOKUME~1\SUPERV~1\LOKALE~1\Temp
The fulle name is:
C:\Dokumente und Einstellungen\supevisor\Lokale Einstellungen\temp

So I must take back the "seamonkey uses shortfilename", Windows does it. Still strange that Mozilla 1.7 has no probs.

Comment 3

12 years ago
Do you see any errors in the JavaScript console if you try it with SM? Please try to delete the file .\components\compreg.dat in the Seamonkey program folder and test again.
Version: unspecified → 1.8 Branch
(Reporter)

Comment 4

12 years ago
deletet the compreg.dat
ftp://ftp.gwdg.de/pub/newfiles.gz -> works as expected.
ftp://ftp.gwdg.de/pub/windows/misc/fax_v526.zip -> works as expected.

Using the same profile as for Mozilla 1.7
-> works as expected

WHERE does that defective compreg.dat come from? Was already a defective one in the original installer? I cannot think of a different source, should be excluded in the installer then.

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 5

12 years ago
You just run into bug 180672/Bug 227439. The file compreg.dat is installation specific, not profile, so it works in Moz 1.7 but not with SM. This file is saved and regenerated every time you start Moz and for unknown reasons it was corrupted.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 6

12 years ago

*** This bug has been marked as a duplicate of 180672 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

12 years ago
Created attachment 208213 [details]
defective (and packed) compreg.dat which makes me being unable to save a file.
(Reporter)

Comment 8

12 years ago
I had this case three times now.
Seamonkey (from www.seamonkey.at) downloaded for Windows.
Installed.
Started browser, wanted to download something (in that case .exe) and got again the same "temp" error. No email account yet, just installed and straight to www.hp.com to get a driver for a printer.
Deleting compreg.dat fixed it in all three cases I had seen it now.
THIS time I captured the defective compreg.dat and put it in here as attachement, maybe you can find out what is really goung wrong.

Thank you all for Mozilla/Seamonkey.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 9

12 years ago
Joachim, this is a dupe; please do not reopen it again.

*** This bug has been marked as a duplicate of 180672 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.