network connections suspend when dialog appears

RESOLVED DUPLICATE of bug 74331

Status

defect
RESOLVED DUPLICATE of bug 74331
14 years ago
14 years ago

People

(Reporter: duvall, Unassigned)

Tracking

1.7 Branch

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

14 years ago
If a dialog appears (say, to prompt for a cookie, or to confirm that yes, I do want to connect to an SSL-enabled site), then any long-term network connections like an IRC session timeout.  This can be quite irritating if you leave such a session open all the time, and while you're away from your computer, a page gets refreshed and tries to confirm a cookie setting.

I also see this when my (NFS-mounted) home directory disappears for a short time, and when it's restored, my IRC session immediately drops.

It's as if the UI and the network are running in the same thread, or are otherwise not properly multiplexing events.

I see this regularly on both Linux and Solaris, and have seen it at least for all of the 1.7 line.  I wasn't using IRC before that, so if the problem existed, I wasn't seeing it commonly.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 74331 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.