Closed Bug 321317 Opened 17 years ago Closed 17 years ago

Remote interface doesn't work under Linux/PowerPC

Categories

(Toolkit :: Startup and Profile System, defect)

PowerPC
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 312154

People

(Reporter: vincent-moz, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.8) Gecko/20051217 Debian/1.5.dfsg-2 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.8) Gecko/20051217 Debian/1.5.dfsg-2 Firefox/1.5

On my Linux/PowerPC machine, the remote interface to open a URL from another application (terminal, shell, RSS reader...) doesn't work.

Reproducible: Always

Steps to Reproduce:
1. Start firefox.
2. From a shell, type "firefox http://www.mozilla.org/".
Actual Results:  
After about 15 seconds, I get an error box saying: "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system."

Expected Results:  
The URL should have been opened in the running Firefox instance.

No problem under Linux/x86 and under Mac OS X. There was no problem either with Firefox 1.0.x.

This bug has also been reported on the Debian BTS:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=343913
Component: General → Startup and Profile System
QA Contact: general → startup
i can reproduce this on my ibook, is a very annoying problem, i must use 1.0.x...
I confirm this bug.  It happens to me the same way as to the reporter.  I have a PowerBook G4 Apple laptop.  It appears on 1.5 version, not on the 1.0 version of firefox.

Eugen
This is a problem for all big-endian systems, the patch in bug 321317 fixes it.

*** This bug has been marked as a duplicate of 312154 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
I meant 312154 of course.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.