view source displays a blank page

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
P3
normal
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: Christine Begle, Assigned: travis)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
this is with today's tip builds (2000031608) on NT.

1. go to http://www.mozilla.org
2. select View | Page Source menu item. 
   -> page is blank

the console has the following error:

BrowserViewSource();
 WEBSHELL+ = 8
WEBSHELL+ = 9
JavaScript Error: TypeError: Components.interfaces.nsIDocShell has no properties
URL: chrome://navigator/content/viewsource.js
Line number: 6

Comment 1

18 years ago
qa -> sairuh
QA Contact: paulmac → sairuh
i don't see this with the beta1 branch bits (opt comm, 2000.03.16.06-nb1b) on
winNT.

methinks view source stuff goes to bill, so reassigning to him.
Assignee: travis → law
(Reporter)

Comment 3

18 years ago
adding travis back to the cc: list since he wrote the code that's causing the 
error.  this is a tip thing, not branch.
(Assignee)

Comment 4

18 years ago
This is mine.... Likely the problem is just a packaging one.  This is not a 
beta issue, I rewrote the view source code in the trunk only.
Assignee: law → travis
(Assignee)

Comment 5

18 years ago
This works for me and I tried on cbegle's machine and it worked there too when 
we ran the correct version with the right path.  If anyone else is seeing this, 
they should make sure they are installing into a clean directory and our 
picking up the right components directory.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
verif.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.