[Win95-JA only] ™ is displayed as ^(TM)

RESOLVED FIXED in mozilla1.8.1

Status

Core Graveyard
GFX: Win32
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: emk, Assigned: emk)

Tracking

({intl, verified1.8.0.2, verified1.8.1})

Trunk
mozilla1.8.1
x86
Windows 95
intl, verified1.8.0.2, verified1.8.1
Bug Flags:
blocking1.8.0.2 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tjp-dl], URL)

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

12 years ago
Reproducable: Always
Steps to reproduce:
1. Navigate to the URL above.
Actual result:
Camino^(TM)
Expected result:
Looks like Camino<sup>TM</sup>
(Assignee)

Comment 1

12 years ago
Created attachment 207094 [details] [diff] [review]
Patch rv1.0

This is a regression of bug 134733.
Bug 134733 assumes that GenerateSingleByte is only used for raster fonts.
But A-functions will also use it for TrueType fonts.
This patch includes a fix for 141132.
timeless:
Do you know the reason why mb[127] and mb[255] are not yet initialized after bug 284436 fixed?
Assignee: win32 → VYV03354
Status: NEW → ASSIGNED
Attachment #207094 - Flags: review?
(Assignee)

Updated

12 years ago
Attachment #207094 - Flags: review? → review?(timeless)
(Assignee)

Comment 2

12 years ago
Created attachment 207095 [details] [diff] [review]
Patch rv1.0 with diff -u8pw (review puopose only)

Comment 3

12 years ago
Comment on attachment 207094 [details] [diff] [review]
Patch rv1.0

corner cases are always hard. perhaps we should use <= 127 and <= 255 instead?

it certainly wasn't intentional on my part.
Attachment #207094 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #207094 - Flags: review?(timeless)
Attachment #207094 - Flags: review+
(Assignee)

Comment 4

12 years ago
Created attachment 207104 [details] [diff] [review]
Patch rv1.1
Attachment #207094 - Attachment is obsolete: true
Attachment #207104 - Flags: superreview?
Attachment #207104 - Flags: review+
Attachment #207094 - Flags: superreview?(neil.parkwaycc.co.uk)
(Assignee)

Updated

12 years ago
Attachment #207104 - Flags: superreview? → superreview?(rbs)
(Assignee)

Comment 5

12 years ago
Created attachment 207105 [details] [diff] [review]
Patch rv1.1 with diff -u8pw
Attachment #207095 - Attachment is obsolete: true
(Assignee)

Comment 6

12 years ago
Comment on attachment 207104 [details] [diff] [review]
Patch rv1.1

Sorry, I missed timeless set the superreviewr.
Attachment #207104 - Flags: superreview?(rbs) → superreview?(neil.parkwaycc.co.uk)

Comment 7

12 years ago
Comment on attachment 207104 [details] [diff] [review]
Patch rv1.1

sr=rbs
Attachment #207104 - Flags: superreview?(neil.parkwaycc.co.uk) → superreview+
checked-in.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9alpha
Comment on attachment 207104 [details] [diff] [review]
Patch rv1.1

Mozilla Japan wants this patch on 1.8.1 branch.
Because it's last chance for fixing this bug on release builds.(Gecko 1.9 may not be support Win9x by using Cairo.)
Attachment #207104 - Flags: approval1.8.1?
Flags: blocking1.8.1?
Attachment #207104 - Flags: branch-1.8.1?(rbs)
Attachment #207104 - Flags: approval1.8.1?

Updated

12 years ago
Attachment #207104 - Flags: branch-1.8.1?(rbs) → branch-1.8.1+
checked-in to 1.8 branch.
Flags: blocking1.8.1?
Keywords: fixed1.8.1, intl
Target Milestone: mozilla1.9alpha → mozilla1.8.1
Flags: blocking1.8.0.2?
Attachment #207104 - Flags: approval1.8.0.2?
Flags: blocking1.8.0.2? → blocking1.8.0.2+
Comment on attachment 207104 [details] [diff] [review]
Patch rv1.1

approved for 1.8.0 branch, a=dveditz for drivers
Attachment #207104 - Flags: approval1.8.0.2? → approval1.8.0.2+
Keywords: fixed1.8.0.2

Updated

11 years ago
Whiteboard: [rft-dl]

Updated

11 years ago
Whiteboard: [rft-dl] → [tjp-dl]
(Assignee)

Updated

11 years ago
Keywords: fixed1.8.0.2, fixed1.8.1 → verified1.8.0.2, verified1.8.1
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.