Right click on date tab breaks context menus

RESOLVED FIXED

Status

RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: roger, Assigned: jminta)

Tracking

Sunbird 0.3a1
x86
Windows XP

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

When I right-click on month or year in Date tab, two menus appear - "classic" context-menu with "New Event..." etc. and month/year change list. Clicking elsewhere in Calendar closes context menu, but list remains open and unresponsive. It's necessary to left click on year/month again to "re-open" the list to make it behave correctly.

Reproducible: Always

Steps to Reproduce:
1. Right click on year or month in Date tab.
2. Click somewhere else in Calendar (ie. window title bar).
3. Try clicking on displayed years/months list.

Actual Results:  
In step 2., context-menu disappears, in step 3. nothing happens.

Expected Results:  
Both context menu and year/month list should disppear, or at least list should react on clicking. Probably year/mont list shouldn't appear in step 1. at all.

Year/month selection list remains on screen even when I switch to another app (like this Firefox I'm filling bug in). After clicking on it, I'm switched back to Calendar, but list still doesn't react.
(Reporter)

Updated

13 years ago
Version: unspecified → Sunbird 0.3a1
(Assignee)

Comment 1

13 years ago
Created attachment 207203 [details] [diff] [review]
only respond to left-clicks

Pretty simple.  Passes in the click event to check for the button number.  Don't show the minimonth popup unless it was a left click.
Assignee: mostafah → jminta
Status: UNCONFIRMED → ASSIGNED
Attachment #207203 - Flags: first-review?(mvl)
Comment on attachment 207203 [details] [diff] [review]
only respond to left-clicks

r=mvl
Attachment #207203 - Flags: first-review?(mvl) → first-review+
(Assignee)

Comment 3

13 years ago
patch checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

13 years ago
*** Bug 325106 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.