hover that changes link decoration causes rendering error on following text

RESOLVED DUPLICATE of bug 300982

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 300982
12 years ago
12 years ago

People

(Reporter: Logan Shaw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051231 Firefox/1.6a1

If you CSS "a:hover { text-decoration: none; }" (i.e. set up a
link so that its decoration changes on hover), moving the mouse
on and off the link causes the text *after* the linked text but
before end-of-line to be drawn incorrectly.  Specifically, it
gets drawn with an overstrike-like effect.

Reproducible: Sometimes

Steps to Reproduce:
1. Move mouse on and off linked text.
2. Watch text immediately after linked text.
3. If the bug doesn't occur, try changing the width of the window or font
   size so that the text is flowed differently.

Actual Results:  
Text after linked text gets an overstrike-like effect, making
it very heavy (and slightly distorted).

Expected Results:  
Text after linked text should be unaffected; only the linked text's
rendering should change when hovering over it.

I'll be adding the offending HTML as an attachment in case
I can't host it at the indicate URL forever.
(Reporter)

Comment 1

12 years ago
Created attachment 207287 [details]
example HTML that exposes the bug.

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 300982 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.