Last Comment Bug 322068 - searching bookmarks should not find nor show live bookmarks children
: searching bookmarks should not find nor show live bookmarks children
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: unspecified
: x86 Linux
: -- enhancement with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://testers.cpan.org/author/RRWO.rss
: 377601 (view as bug list)
Depends on: 453530 livemarksIO
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-01 10:18 PST by Robert Rothenberg
Modified: 2012-02-25 03:00 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Robert Rothenberg 2006-01-01 10:18:07 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I have some live bookmarks in my Personal Toolbar Folder (actually in a subfolder of the Personal Toolbar).

When I open the bookmarks sidebar (Ctrl+B) or am in Manage Bookmarks, and I try to search for a keyword, then all the live bookmarks show up in the search.

I can see how this is a feature. But it can be annoying too: suppose I have the above URL included as a bookmark, and then search for the keyword "linux". I have dozens of bookmarks which match that keyword, so my static bookmarks are buried inside all of the live ones.

It would be nice to have an checkbox or toggle button when viewing bookmarks to ignore live bookmarks.

Reproducible: Always

Steps to Reproduce:
1. Add a live bookmark such as the included URL to the Personal Toolbar
2. Manage Bookmarks or Ctrl+B
3. In the search box, enter a common keyword for the live bookmarks
4. Notice that static bookmarks are buried in live bookmarks
Comment 1 Philip Withnall (unavailable) 2006-03-01 14:30:01 PST
Confirmed. Sounds like a good feature to have. :-)
Comment 2 Phil Ringnalda (:philor) 2007-04-15 20:47:43 PDT
*** Bug 377601 has been marked as a duplicate of this bug. ***
Comment 3 Marco Bonardo [::mak] 2009-01-16 06:06:48 PST
really, should be the default since live bookmarks childre are not users' created bookmarks
Comment 4 Marco Bonardo [::mak] 2012-02-25 03:00:41 PST
fixed by bug 613588

Note You need to log in before you can comment on or make changes to this bug.