If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

WPAD: Auto-Detect Proxy not working until MIME type set

UNCONFIRMED
Unassigned

Status

()

Core
Networking
P5
major
UNCONFIRMED
12 years ago
8 days ago

People

(Reporter: Joseph William Baker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-would-take])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

http://wpad/wpad.dat  should be loaded and run to set the default proxy settings and it fails.

Even specifying the url doesn't work.

If I manually set the values it does work.

Reproducible: Always



Expected Results:  
I expect the browser to load http://wpad.nelfc.com/wpad.dat then run the javascript then plug in the values and have the browser begin useing the proxy server.
(Reporter)

Comment 1

12 years ago
After adding in the mimetype in apache's configurations this started working as expected.

However on Windows firefox clients 1.0.7 and 1.5 there wasn't an issue with acting on the wpad.dat file.

Here's what I added to apache's mime type listings.

application/x-ns-proxy-autoconfig dat

I don't know whether this should be closed or not.

Keep up the great work!
-Joe Baker
I'd put this down to server misconfiguration.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 3

9 years ago
I wasn't aware of this problem, it might need to be documented....

I'm going to reopen this, for now.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: Auto-Detect Proxy not working for Gentoo Built deerpark → WPAD: Auto-Detect Proxy not working until MIME type set

Updated

9 years ago
Component: Preferences → Networking
Product: Firefox → Core
QA Contact: preferences → networking
Whiteboard: [necko-would-take]
Bulk change to priority: https://bugzilla.mozilla.org/show_bug.cgi?id=1399258
Priority: -- → P5
You need to log in before you can comment on or make changes to this bug.