entering double http:// into Firefox followed by ANY domain resolves to microsoft.com!

VERIFIED DUPLICATE of bug 310826

Status

()

Firefox
General
--
trivial
VERIFIED DUPLICATE of bug 310826
13 years ago
8 years ago

People

(Reporter: Allison, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I know this is obscure, but i thought you'd be fascinated by what happens here.  I was using an automated program to generate my html, and I wasn't paying attention and I entered http:// into a field that was prepopulated with it, followed by my own domain podfeet.com, so I had entered http://http://podfeet.com.  i tested all my links (luckily) and in Firefox (not in Safari or Mozilla) it resolved to Microsoft's website!  i just tested it with http://http://mozilla.org and it also goes to Microsoft.  I have no problem if you decide to not fix it, chance are slim anyone will ever find it again, but I thought you might find it at the very least interesting!

Reproducible: Always

Steps to Reproduce:
1.in url field enter http://http:// followed by any domain name
2.enter
3.resolves to http://www.microsoft.com

Actual Results:  
see above

Expected Results:  
Safari returns an error saying I'm not connected to the internet if I do this mistake, and Mozilla changes it to "http://www.http.com//mozilla.org" and says not found.

given an error message, or taken a diehard Firefox user to ANY website on earth other than Microsoft!  ironic, isn't it?

*** This bug has been marked as a duplicate of 310826 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.