checked radio buttons aren't reset after page reload (possible duplicated of 252691)

RESOLVED DUPLICATE of bug 46845

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 46845
12 years ago
12 years ago

People

(Reporter: Paul Gibbs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

On a simple form with two radio buttons (neither of which are "selected" by default, on page load), if I select one of the bullets then reload the page by clicking on the blue RELOAD CURRENT PAGE toolbar button, then that radio button remains checked.

I think this is a bug because I assume a page refresh will load the page from scratch - not remember selected form elements.  This is not Firefox's form helper selecting it helpfully (it hasn't asked me to save/don't save preferences for that form).

Reproducible: Always

Steps to Reproduce:
1. Create basic HTML page with a form with two radio buttons - ensure neither are set to be "selected" by default/on page load.
2. In firefox, select either of the radio buttons, then click the blue RELOAD button on the main toolbar.
3. The radio button - that you just selected - remains selected!

Actual Results:  
The selected radio button is "selected" by default/on page load.

Expected Results:  
NOT select a default radio button unless explicity specified in the HTML.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.