Closed Bug 322658 Opened 14 years ago Closed 14 years ago

Form autofill could be executed before onKeyPress() is activated

Categories

(Toolkit :: Form Manager, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 286933

People

(Reporter: xkjyeah, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Under "Street Search", this website roughly does this:
onKeyPress="if (key == 13) thisform.submit()". Autofill on this input box does not work.

Reproducible: Always

Steps to Reproduce:
1. I type in part of the street name and the automatic completion box appears
2. I use the arrow keys to navigate to the previous entry then press <enter>
3. Form is submitted.

Actual Results:  

Problem: The form is submitted _before_ the entry is autofilled. So only a partial street name (whatever I typed earlier) is submitted. e.g. only "Toh Tu" of "Toh Tuck Road" is sent. This is a problem with the website's unnecessary use of Javascript, but would be nice if Mozilla accomodates for such silly cases. Will inform the website.


Expected Results:  
Autofill before onKeyPress() is activated?

*** This bug has been marked as a duplicate of 286933 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.