Alternative text given to links not displaying.

VERIFIED DUPLICATE of bug 25537

Status

()

defect
VERIFIED DUPLICATE of bug 25537
14 years ago
14 years ago

People

(Reporter: hareeshn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I was designing a website and I noticed that, when the site is opened in FireFox 1.5, the alternative text given to links are not at all displaying. When the same is opened in IE it is working fine. I used the following code to assign an alternative text to an image.
<img src="images/img_header.jpg" alt="newnmedia - complete design solutions - print | media | web" width="600" height="72" border="0"/>
Can you please tell me how to solve this problem?
Regards
Hareesh N. N.

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.firefox.com/ both in IE & FireFox.
2.Move the mouse over any one of the given logos.
3.You can see the alternative text in IE but not in FireFox.

Actual Results:  
I can't see the Alternative text in FireFox, but can view it in IE.

Expected Results:  
Show alternative text to each link if it is available, else display the link location(IE dont have this feature).
The alt attribute is for when images cannot be displayed. The title attribute is for displaying a tooltip on working images.


*** This bug has been marked as a duplicate of 25537 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Yes, it can be generated when the image is unable to get loaded. But just think of a situation. The button name "Log-in". When the mouse is rolled over it says "Member's Log-in Area". This is only an instance. Actually designers use Alt text to attach some more information about the button. Google searches for these Alt texts as well to display the results. So, please enable this feature.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
No. This bug is a duplicate of bug 25537, I suggest you read that bug to find out why, particularly bug 25537 comment 31. Do not reopen this bug.


*** This bug has been marked as a duplicate of 25537 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
verified - please use TITLE for these popups, not ALT
I agree with all. It is better use Title instead of Alt for showing tool tips. I searched in bugzilla to get an answer about this before posting, but I dont get relevant results. That's why I posted it here.
The only problem may occur: some sites already done uses Alt tag to show tool tip, b'cse IE permits that, now designers should re-build them.
Thanks to all..
You need to log in before you can comment on or make changes to this bug.