[l10n] Bookmark Menu and Bookmark Bar collection labels don't get strings from Localizable.strings

RESOLVED FIXED in Camino1.0

Status

RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: m.testi, Assigned: sfraser_bugs)

Tracking

({fixed1.8.0.1, fixed1.8.1, regression})

unspecified
Camino1.0
PowerPC
Mac OS X
fixed1.8.0.1, fixed1.8.1, regression
Bug Flags:
camino1.0 +

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.4.1) Gecko/2002 - Netscape 6.2, Mac OS X
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.4.1) Gecko/2002 - Netscape 6.2, Mac OS X

"Bookmark Menu" and "Bookmark Bar" labels appear in English althought the 2 strings are present inside the Italian Localizable.strings file.

Reproducible: Always

Comment 1

13 years ago
The issue is that they always read the names from the bookmark file, so once they have been initially created in one language they will always be displayed in that language.  There's no reason not to reset the name on each initial load at the same time their icons are set and the transient special folders are created.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

13 years ago
Assignee: mikepinkerton → sfraser_bugs
Flags: camino1.0?
Target Milestone: --- → Camino1.0
We need this for 1.0.
Flags: camino1.0? → camino1.0+
(Assignee)

Comment 3

13 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8.0.1, fixed1.8.1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.