User cannot launch multiple JVM sessions in FireFox, works fine in IE and older Mozilla (1.6)

RESOLVED WORKSFORME

Status

()

Firefox
Shell Integration
--
major
RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: Michael, Unassigned)

Tracking

2.0 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

We use Oracle application servers.  When the user opens a second browser instance or tab and tries to access a second instance of Oracle web-based app, the user gets an error message from Oracle, "failed to connect to the server".  When using IE or Mozilla, multiple windows work fine.

Oracle 9i, Jinit 1.3.1.9 plugin (also tried 1.1.8), FireFox 1.x (tried 1.0.5-7 and 1.5), Win 98/2000.

Here's what the java console shows upon a successful connection:

Loading http://apps-1.alliednational.com/forms90/webutil/webutil.jar from JAR cache

Loading http://apps-1.alliednational.com/forms90/webutil/jacob.jar from JAR cache

Loading http://apps-1.alliednational.com/forms90/java/f90all_jinit.jar from JAR cache

RegisterWebUtil - Loading WebUtil Version 1.0.5 Production

Loading http://apps-1.alliednational.com/forms90/java/alliedico.jar from JAR cache

Loading http://apps-1.alliednational.com/forms90/java/hst65.jar from JAR cache

connectMode=HTTP, native.

Forms Applet version is : 902110



And here's a failure message from the java console:

java.lang.ClassNotFoundException: java.io.IOException: open HTTP connection failed.

	at sun.applet.AppletClassLoader.getBytes(Unknown Source)

	at sun.applet.AppletClassLoader.access$100(Unknown Source)

	at sun.applet.AppletClassLoader$1.run(Unknown Source)

	at java.security.AccessController.doPrivileged(Native Method)

	at sun.applet.AppletClassLoader.findClass(Unknown Source)

	at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at java.lang.ClassLoader.loadClassInternal(Unknown Source)

	at java.lang.Class.forName0(Native Method)

	at java.lang.Class.forName(Unknown Source)

	at oracle.forms.handler.UICommon.instantiate(Unknown Source)

	at oracle.forms.handler.UICommon.onCreate(Unknown Source)

	at oracle.forms.handler.ButtonItem.onCreate(Unknown Source)

	at oracle.forms.engine.Runform.onCreateHandler(Unknown Source)

	at oracle.forms.engine.Runform.processMessage(Unknown Source)

	at oracle.forms.engine.Runform.processSet(Unknown Source)

	at oracle.forms.engine.Runform.onMessageReal(Unknown Source)

	at oracle.forms.engine.Runform.onMessage(Unknown Source)

	at oracle.forms.engine.Runform.sendInitialMessage(Unknown Source)

	at oracle.forms.engine.Runform.startRunform(Unknown Source)

	at oracle.forms.engine.Main.createRunform(Unknown Source)

	at oracle.forms.engine.Main.start(Unknown Source)

	at sun.applet.AppletPanel.run(Unknown Source)

	at java.lang.Thread.run(Unknown Source)


Again, this works fine with IE and older Mozillas.

Reproducible: Always

Steps to Reproduce:
1.Open Oracle web page, which inits a JVM
2.Open second Oracle web page in a new tab which should launch second JVM
3.Second instance can't access app server.
What about in Firefox 1.5?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> What about in Firefox 1.5?
> 

Tested with FireFox 1.0.5 through 1.5, same result.

-Michael
(Reporter)

Comment 3

11 years ago
The issue is still present in 1.5.0.3.

Until it is addressed, my users are forced to use IE.

Is there anyone out there who can at least acknowlege the issue?  For anyone trying to use FireFox with Oracle web forms, this is a major problem.
(Reporter)

Comment 4

11 years ago
Still waiting for someone, anyone, to even acknowledge the issue!

The issue is still there in the latest 1.5 version, and in every 2.0 beta I have tried.

Is anyone there....

Hellooooooooo!!!
Version: unspecified → 2.0 Branch
There is no reason a second tab should open a second JVM. We use a single JVM for all mozilla tabs and windows by design; using a separate JVM for each window sucks up significant amounts of memory.

jst, WONTFIX/INVALID?
(Reporter)

Comment 6

11 years ago
I understand Benjamin's statement about two JVM's being a system hog, but I really need to be able to have multiple sessions in my browser.

Just like I was able to do in Mozilla and can still do in IE.

Whether the system resources are an issue or not, there is a bug in Firefox that prevents it from happening.

Please fix.
(Reporter)

Comment 7

11 years ago
Just tried it in released version of 2.0.  It is still an issue.

Any reason this is being ignored?
(Reporter)

Comment 8

10 years ago
Tried again with latest release of Oracle 10g and latest release of Firefox.

Still an issue.

Comment 9

8 years ago
This bug was reported using a version of Firefox that security and stability updates are no longer provided for.  All users are strongly encouraged to upgrade to Firefox 3 by selecting 'Check for Updates' in the Help menu or by going to http://www.mozilla.com/en-US/firefox/firefox.html

If you can no longer reproduce this bug using the latest Firefox 3.0.x version, please change the status of this bug to 'RESOLVED' 'WORKSFORME'.

If you can still reproduce this bug, please provide additional details to help resolve this issue.
(Reporter)

Comment 10

8 years ago
The issue is no longer present in Firefox 3.0.11.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
FIXED is only for when a patch is checked itot he tree. WFM
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.